Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an Asus RT-N12D1, and I installed the tomato firmware by shibby (tomato-K26-1.28.RT-N5x-MIPSR2-112-Max.trx and tomato-K26-1.28.RT-N5x-MIPSR2-114-Max.trx). However I found that the connection can be really unstable. Whenever I stream youtube videos on TV via Chromecast ( I tried both the cast from iPad and Win7, both can reproduce the problem), the router will frequently restart itself, leading to a loss of connection and subsequent reconnection.

I want to get this problem fixed, but I don't know how. Is there anyway where I can troubleshoot the problem, or is there anyway I can collect enough log information so that I can then present to the original developer for a fix ( maybe)?

Edit: There is only me in the house and I don't share line with anyone else, so it is unlikely that it is due to congested line.

share|improve this question

3 Answers 3

You are using the tomato firmware by shibby because of Chromecast. However, some people have shown that it is possible to connect to Chromecast with less-advanced router firmware.

The article Connecting your Chromecast on Belkin N300 Router lists the following steps:

  • Disabled uPnP (Belkin Admin > Utilities > System Settings > UPnP Enabling > Disable)
  • Updated firmware (now running F9K1002_WW_1.00.16 Belkin Wireless Router Version : 1.00.16)
  • Disabled ICMP Blocking (Belkin Admin > Firewall > WAN Ping Blocking > Block ICMP Ping > [uncheck] )
  • Added IP address of Chromecast to DNS (Belkin Admin > Firewall > DMZ > checked Enable with Private IP of dongle)

This Google help article gives more advice :
We cannot connect with your Chromecast from this computer - Chromecast Help.

A useful article : Guide to Install Tomato firmware on Asus RT-N12 HP B1 C1 D1, says that the original Asus firmware may have better performance than Tomato, and also implies that shibby has cut out many options. The Asus latest firmware and utility from September 2013 is available here.

You may also solve your problems with Tomato by trying the alternative firmware DD-WRT. The Asus RT-N12 up to revision C is supported. It is also claimed here that even the B1 firmware works for the D1.

My last advice, if you wish to stay with the tomato firmware by shibby, is to ask for help on their website. If the developers answer, they will be able to tell you what log information is required. (And if they don't answer, there is no point in doing that.)

share|improve this answer
1  
I know dd-wrt is supported, but I have done the configuration in tomato with the help from outside and I am not sure I know how to setup dd-wrt on my own. –  Graviton Nov 15 '13 at 8:49
    
My best advice in this case is to ask for help on the website of tomato firmware by shibby. I don't understand the language, so can't help. –  harrymc Nov 15 '13 at 11:10
    
BTW, I note that there is newer Tomato version by shibby. You should try the latest version before asking for help. –  harrymc Nov 15 '13 at 13:52
    
Yes, I did the the latest version, same results. And no, asking help on tomato website doesn't help. I didn't got any response at all. –  Graviton Nov 18 '13 at 7:24
1  
To the down-voters: you are not helping at all. –  harrymc Nov 18 '13 at 9:46

I have tomato on many of my routers, and it sounds like traffic is either too high or there are too many devices connected.

Try messing with the QoS settings and set a bandwidth limit that is a little lower than what you know it actually is. (run a speed test of sorts and find out your real-world speeds and just lower it a bit so that the router is less taxed)

Also try lowering your lease time so that it knocks off unused reservations. I don't know why, but when my tomato routers have too many leases they can sometimes fail. I found lowering the lease time and forcing it to clean up resolves some random restarts.

You may also want to try older builds. Did you pick your firmware based on your chip-set? Some versions are much more reliable with different chip-sets.

EDIT: I have also had connection issues with tomato when using WPA2 aes. Switching to TKIP helped as well.

Also, try only broadcasting N or only G and see if it being mixed(assuming it is by default) is a part of the issue.

share|improve this answer
    
I have only 1 user in the house, that's me. So I don't think it's a traffic congestion problem –  Graviton Nov 22 '13 at 9:15
    
Have you tried everything else? That was only one possibility. –  Me Bender Nov 22 '13 at 16:13

I think the problem with the instability can be your firewall being at full restriction and you will need to lessen the blocks on the firewall for it and makes sure that the RT-N12 is compatible with the shell because that can cause an issue too. Also, make sure that IPV6 is enabled if it is not or out of date it will cause you so much trouble and cause instability it can freeze you computer.Also, WPA2 password service doesn't like tomato i don't know why it just doesn't if you change the password type to wep key and use the same password you should have it fixed.

share|improve this answer
    
Why do you say so? BTW, the instability also occurs when I am connecting via iPAD, so the antivirus is not relevant here –  Graviton Nov 22 '13 at 6:11
    
i edited what i said just now –  user2993737 Nov 22 '13 at 23:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.