Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Hope you can help me with this.

I have setup like this.

Windows 7 Enterprise (64 bit) as a HOST running VirtualBox 4.2.4 Two virtual machines running LinuxMint 12 (64 bit). VM-1 with one network interface: internal (net1) BR-1 with two network interfaces: eth0, internal (net1) and eth1, bridged to ethernet adapter.

The idea is to let BR-1 act as a bridge for VM-1 to another host which will have a similar setup. This is a test-project so don‘t ask me why i‘m doing this.

On BR-1 I have created bridge over both of the interfaces (eth0 and eth1). My problem is that ip-frames are not passing through the bridge to the other host. The bridge is seeing all the mac-addresses but it seems that VirtualBox is not allowing traffic from eth0 (internal) to be forwarded to eth1 (bridge).

Has anyone tried this or have a opinion on this ?

share|improve this question
    
Maybe this is intentionally blocked? You're using "Internal Network" for a reason. You don't want traffic from an "Internal Network"-device seeping through to a physical device. (Well... you do, but that's the opposite of what the "Internal Network" is suppose to do :) –  Rik Nov 12 '13 at 16:03
    
Yes that is true with "Internal Network" but I was not trying to go around that. Just to forward the traffic in a controlled way to the bridge interface. I found what the reason was after some deep digging and using Wireshark to monitor the devices. The bridge was working fine but the host was not forwarding the ip packets. So ping would never work between clients on different hosts. The solution was to enable IP forwarding on the host (Windows 7). You have to change the registry to enabled that. Now it works. :-) –  sammi.is Nov 12 '13 at 18:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.