Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When creating a System Restore point manually, I get a nondescript error message:

The restore point could not be created for the following reason:

Access is denied. (0x80070005)

I've been troubleshooting for hours. I have...

  • Uninstalled my virus scanner (Microsoft Security Essentials)
  • Disabled System Restore and rebooted (to clear out all restore point files)
  • Rebooted in safe modes
  • Tried to find which file/folder might have access denied (no clues)
    • Searched Event Logs
    • Run SysInternals ProcMon
  • Attempted to give "Full Control" security permissions recursively to "C:\System Volume Information" for SYSTEM, LOCAL_SERVICE, SERVICE, plus my user account.

No luck at all.

I eventually discovered Windows is able to create Restore Points automatically:

  • Since I no longer had any restore points (due to troubleshooting) I decided to run Windows Backup(**)... Low and behold, a system restore point got created!

So it seems I have a workaround. Still, it would be great to get to the bottom of this.

These are the only system changes I can think of over the last few months. They seem like long-shots, but could they be relevant?

  • From Microsoft Update, I installed and ran a "Disk Cleanup" plugin that clears out old Service Pack update stuff
  • I'd previously granted "Full Control" security permissions recursively to "C:\System Volume Information" for my user account, to snoop around. Could I have overwritten some important permission?

(**) When I then asked Windows Backup to delete my backup, it said "Access is denied. (0x80070005)" Arrrgh! :-) Fortunately I can do this myself. But could this be another clue?


UPDATE: I also cannot revert to a restore point: same error given.

Workaround: restore after booting in Safe Mode (NB: cannot be undone)

share|improve this question
1  
The sheer fact you are adjusting permissions is a sign your Windows installation is corrupt. Have you tried restoring the original permissions to the folder you changed? –  Ramhound Nov 13 '13 at 14:17
    
How exactly did you grant yourself those permissions? What are the permissions currently on the System Volume Info partition? –  Ƭᴇcʜιᴇ007 Nov 13 '13 at 14:29
    
Not sure what the original permissions were now. :-) I'm hoping/expecting that setting (SYSTEM, LOCAL_SERVICE, SERVICE, luke) recursively would be a superset of the defaults & what the system requires. –  Luke Usherwood Nov 13 '13 at 14:48
    
@LukeUsherwood - I would load up one of Microsoft's free virtual machines and check what the permissions should be. Even if you restore the original permissions there is no guarantee your previous changes don't do something else. –  Ramhound Nov 13 '13 at 14:49

1 Answer 1

up vote 1 down vote accepted

I've just fixed this issue on a Windows 7 laptop. Make sure SYSTEM and Administrators group has read and write access to C:\system volume information and sub folders! especially SPP. Any assistance on checking or making this change, let me know.

Graham

share|improve this answer
    
Yes! Reapplying rights for SYSTEM to the SPP folder recursively fixed the issue. Many thanks! (I don't know how I managed to break that. Maybe it lost some inherited permission??) –  Luke Usherwood Nov 10 '14 at 0:20
    
This doesn't work on Windows 8. –  desbest May 17 at 5:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.