Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I´m trying to connect to my Samba share in my QNAP NAS from a Windows 8 client. The name and password are the same both in the Windows client and the NAS server. I got an authentication error, so I tried the same thing in Windows 7 and it works. So what is the difference between Windows 7 and Windows 8? What can I do to authenticate correctly without needing to use different credentials to access my Samba share?

share|improve this question

migrated from Nov 13 '13 at 21:20

This question came from our site for system and network administrators.

i also tried to change some security group policies without sucess. Samba on server is configured so it can be authenticated with NTLM2 and it can encript password. – Abraham Borbujo Nov 13 '13 at 1:25
Ok... one other idea. How about the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa key, change the value of LmCompatibilityLevel to whatever it is on your Windows 7 machine, and reboot again – Ryan Ries Nov 13 '13 at 1:43

Windows 8 and Windows 2012 introduced a "Secure Negotiate" feature to SMB, and they're configured to require Secure Server Signing by all SMB servers. The fix is to either tell the SMB server to enable signing (assuming your server is capable of signing), or to tell your Windows 8 client(s) to disable Secure Negotiate.

See Microsoft's description of this problem, or this page dealing with the same issue on a NetApp filer.

QNAP may have an upgraded firmware for your NAS which supports SMB 2.24 or newer, and the SMB signing necessary for native communication with newer Windows clients. They at least do for the Turbo NAS. So if you have a Turbo NAS, you could take this route.

Disabling Secure Negotiate on a Windows 8 client is easy, though. Start PowerShell, and enter the following command:

Set-ItemProperty -Path "HKLM:\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters" RequireSecureNegotiate -Value 0 -Force

Note that this can also be easily changed later with -Value 1, if an upgrade to the NAS firmware comes later on.

share|improve this answer
Hi. Qnap last firmware (4.0.2) supports SMB 1 because the samba version is 3.5.2 . I tried changing the reg value as you told but is still the same. To make this more clear, i can access my samba shares if i enter user and password after auth error. So if i force "different" credentials and remember those, i can access the shares. But my goal is not to have to make this way. I want to access directly as i did in windows 7, because user and password are the same. Thanks – Abraham Borbujo Nov 13 '13 at 10:02
Hi. I found new qnap firmware in website (not in autoupdate). So new one is 4.0.5 that comes with samba 3.6.18. Now it is compatible with SMB 2. But i´m getting the same problem with authentication in windows 8. Any ideas? Thanks – Abraham Borbujo Nov 15 '13 at 13:46
I have the same issue, @AbrahamBorbujo. Trying to access a QNAP share with a Windows 8 computer asks for credentials. Accessing the same share with the same user on Windows 7 goes right in. – Jack Nov 7 '15 at 19:36
I just made some test and discovered that Windows 8 can create two different types of user accounts. If you choose to create a new account without log into Microsoft account (local account) you can autenticate normally as windows 7 did. But if you chose the Microsoft account type, then you cannot acces samba shares as usual but manually writing credentials. – Abraham Borbujo Nov 10 '15 at 20:52

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.