Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have uTorrent 3.3.2 installed on two computers and on both computers it says that the port is not properly forwarded when I do the built-in port test.

a

I followed this guide to forward the ports.

Application  Protocol  Source Net  Port from  IP Address     Port to  Enable
uTorrent 1   Both                  31090      192.168.0.103  31090    Yes
uTorrent 2   Both                  37065      192.168.0.104  37065    Yes

Do I have to add something in the Source Net field, or just leave it blank? I've applied the settings (Apply Settings) and rebooted the router (Administration, Management, Reboot router) but I still don't get a check mark (pass) on the port test. I also tried changing the Source Net to 0.0.0.0 but to no avail.

I've also checked the Windows Firewall settings. Two exceptions were added when uTorrent was installed, one for TCP and one for UDP. I also tried adding a port exception manually. I even tried disabling the firewall but to no avail.

Are these settings correct? I'm not sure about the Port from, Port to and Source Net fields. And is there another way to check if the port is in fact being forwarded to get a second opinion?

Update 1 - UPnP

I'm not sure if this matters but "Enable UPnP port mapping" and "Enable NAT-PMP port mapping" settings were enabled in uTorrent. But on the DD-WRT router, the "UPnP Service" was disabled. I have now enabled it, and also removed the manual port fortwards I had added earlier. I applied the settings and rebooted the router. Now I can see "Teredo" in NAT, UPnP, Forwards. So it seems to be doing something, but I still get the yellow check mark in uTorrent when I do the port test. While typing this, another "Toredo" entry just showed up for the second computer (192.168.0.104).

b

Update 2 - Now open

Okay, it appears to be open now. I guess enabling the "UPnP Service" on the router did the trick? Here's what it looks like now in the router settings.

c

The port appears to be open, both in uTorrent and on yougetsignal.com.

d e

Update 3 - Manual forwarding without UPnP

I'm not sure I want UPnP enabled. Is it safe to have UPnP Service enabled? What kind of implications does that have? Does that mean the router will be dynamically accepting all connections on all ports as they come in? I still want to manually forward the port I want.

I have disabled the UPnP Service. After doing that, the entries in the "Forward" list (as seen on the screenshot above) were removed. Also, the yougetsignal.com website reports that the port is closed. At the same time, the built-in uTorrent port test reported that the port was still open. I don't trust that, it appears to be a false positive. So I rebooted the router, and now the port is reported as closed in uTorrent as well.

I currently don't have any port forwarding rules under "Port Forwarding". Where do I go from here? How do I manually set up a single port forward in DD-WRT without having to enable UPnP Service?

Update 4 - Got it!

I've gone back to square one and I think I got it now. I disabled "UPnP Service" and added only one forwarding rule for one of the computers under "Port Forwarding" menu. I then rebooted the router.

Now the built-in uTorrent port test says that the port is closed, but the web based port tester says it's open. I don't trust the uTorrent port test. So I'm pretty sure it's open now, not only because Yougetsignal.com says so, but because I got upload speeds of up to 500 KB/s and that's a good sign that there is outgoing traffic now.

f g h i

While typing this I've also added a forwarding rule for the second computer and rebooted the router, and after starting up uTorrent on that machine (to begin port forwarding), it too now appears as closed in uTorrent but open on the web based port tester. It was showing up as closed at first, but I solved that by starting uTorrent activity. My guess is that the router was still blocking the port until I got some network activity going on.

j

Note how there's a small icon in the bottom right corner of uTorrent shows a green check mark. Whatever that means... This icon used to indicate that the port is open. At least that was the case in uTorrent version 1.6 or so. But now, if I click that icon I get to the port testing dialog, as usual, and if I do the port test I get a yellow check mark and a statement saying that the selected port is closed. Now what do you make of this?... at the very best it's an ambiguous and inconclusive result. If that tells us anything at all...

I don't know why it didn't work the first time. Looking back at it now, I see that have done everything correctly. Perhaps I forgot to click on the right buttons to get the changes properly registered with the router. There is sort of a "sequence" you have to go through. You first add the lines for port forwarding, then add the information, click Save once or twice, then Apply Settings, and then reboot. It's like a ritual.

share|improve this question
    
You did everything correctly, from what you're saying. The source net field should be blank if you want all traffic to be accepted. Try testing with this tool to see if it can reach your port: yougetsignal.com/tools/open-ports –  Moses Nov 13 '13 at 22:00
    
Another thing to try is simply switch to a different port. Also make sure that you put uTorrent in the Firewall exception list, not just the port entry. It would be in "Add A Program to Windows Firewall". –  Moses Nov 13 '13 at 22:00
    
@Moses According to the web page you linked to the ports are closed. –  sammyg Nov 13 '13 at 22:15
2  
Please note that the "built-in port test" ("Setup guide test") in uTorrent is not always working correctly and you should rely on other services to check the ports. (I had the same "problem" a few weeks back and searched the uTorrent-forums to find that out) –  Rik Nov 13 '13 at 22:45
1  
@Sammy Yeah, that little icon in the right corner is confusing. It indicates if you are uploading to peers. It does not mean your port is open. If you download from a peer that same peer can download from you without port-forwarding so icon is green. It then uses the same port you use for download (but others can't establish a new connection). I had the same problem. Icon was green but download speed was lousy after which i discovered my port was closed (after a router change). Luckily i didn't stay long with the built-in test and discovered soon it was defective. –  Rik Nov 14 '13 at 8:42

2 Answers 2

Are these settings correct?

Yes, they definitely are. You must be sure that the two PCs you're connecting are at those exact addresses, i.e. you didn't accidentally reverse their IPs, and they are either static IPs, or their MACs are hardcoded in the DHCP server configuration. This is to ensure they don't change.

uTorrent should have already configured the Windows firewall as needed (both Port and Application entries).

And is there another way to check if the port is in fact being forwarded to get a second opinion?

You can test this using a program such as netcat for Windows, connecting to TCP port 31090 on 192.168.0.103 from 192.168.0.104 and then repeating in the other direction. If connection succeeds, then the PCs are configured correctly (it is possible that a firewall setting allows connecting from the intranet but not from the internet, thus rendering inter-computer testing meaningless; however, I consider this possibility as remote).

You can also use winpcap (www.winpcap.org) while you run the uTorrent check, to verify that indeed UDP and TCP packages are being sent to the PC (you'll run both uTorrent and winpcap from the same PC you're testing). If you don't see incoming packets, either there's a problem on the DD-WRT (their page says such might be fixed by hard resetting), or your ISP is filtering uTorrent traffic, or the testing site isn't functioning properly. You can verify the filtering hypothesis by having your own machine portscanned.

share|improve this answer
    
Yes, I have the MAC address hard coded for both computers. I have DHCP reservation set up for those two IPs. Just to clear things up, the two computers are not using uTorrent to share files between each other, but rather to share files with the external (WAN) network (Internet). You seem to have gotten that impression. –  sammyg Nov 13 '13 at 22:28
    
No, no, I understand you want to share on the Internet. But you can try connecting from one PC to the other as a simple, albeit not conclusive, diagnostic: if you can't connect the two PCs, trouble must exist at PC level, not (only) at DD-WRT level. –  lserni Nov 13 '13 at 23:00
    
OK. Well, I can certainly reach the other PC if that's what you mean? I can connect to it remotely, I can access shares on it, I can see it in the work group (Start menu, Network). I can ping between them. I haven't tried netcat or winpcap. –  sammyg Nov 13 '13 at 23:14
up vote 0 down vote accepted

Automatic - UPnP Service

You can forward the port using UPnP Service (see update 1 and 2 above). This is not really what I want, since I only need to forward a single port (OK, two ports at most). But I'll post a small step by step guide here in case someone else finds it useful.

In uTorrent...

  1. Open uTorrent.
  2. Go to Options, then Preferences, and click Connection.
  3. Make sure Enable UPnP port mapping is enabled.
  4. Make sure Enable NAT-PMP port mapping is enabled.
  5. Make sure Add Windows Firewall exception is enabled.
  6. Make sure Randomize port each start is disabled.
  7. Note down the port number (i.e. 31090) and click OK.

In DD-WRT settings...

  1. Open the DD-WRT interface (in my case 192.168.0.1) in a web browser.
  2. Navigate to NAT/QoS, UPnP.
  3. Set UPnP Service and Clear port forwards at startup to Enable and click Apply Settings.
  4. Navigate to Administration, Management, and click on Reboot Router.

Start uTorrent and wait a few minutes. If you have the NAT page open in the router interface you will see when the uTorrent port is successfully forwarded. You can then try running the port test in uTorrent.

(Edit: The built-in port tester in uTorrent is not reliable, as we have concluded above. Use an external resource like a web based port tester, such as yougetsignal.com.)

Manual - Port Forwarding

Follow the steps above for uTorrent. Then continue with the steps below.

In DD-WRT settings...

  1. Open the DD-WRT interface in a web browser.
  2. Navigate to NAT/QoS, UPnP and make sure the UPnP Service is set to Disable.
  3. Click on Save, and then Apply Settings.
  4. Navigate to NAT/QoS, UPnP, Port Forwarding.
  5. Click on Add button to add a new empty line.
  6. Type in a name for the rule under Application. This can be anything.
  7. Select TCP or UDP as Protocol, or select Both.
  8. Leave the Source Net field blank (unless you have a reason not to).
  9. Type the port you want to open in the Port from field (remote port).
  10. Enter the IP Address of the computer you want to forward traffic to.
  11. Type the port you want to use on the target machine (local port). You can use the same port.
  12. Check the Enable box and click Save.
  13. If you need to open more than one port, repeat steps 5 - 12, otherwise go to the next step.
  14. Click on Apply Settings.
  15. When you're done adding new ports, navigate to Administration, Management and click on Reboot router.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.