Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

One of the more annoying bugs in Windows XP is the tendency for the Task Manager icon to not show up in the tray (aka the notification area). Sometimes it does, sometimes it doesn't, and it's not consistent enough to have an obvious cause. Looking on Google turns up a bunch of forums that have the same problem but no working solution.

Why does the task manager icon sometimes not show up? How can I repair it when this happens (how can make it show up when it's missing)? How can I prevent it from not working in the first place, so that I don't have to worry about repairing it after the fact?

share|improve this question
    
Why do you want it in the notification area? You use it to track CPU/RAM load? –  Ivo Flipse Jul 17 '09 at 7:28
    
I know you can set it to minimize to the tray, which doesn't work if you close it outright — is this a different problem? Sounds like it. –  jtbandes Jul 17 '09 at 7:29
    
@Ivo: yes, to see CPU usage at a glance. @jtbandes: yes, this is a different problem. The icon is supposed to show up there any time Task Manager is open; "Hide When Minimized" takes advantage of the fact that clicking on the icon brings up the Task Manager. The bug is that the icon is not there. –  Jason Owen Jul 17 '09 at 8:20
    
@owenja: yeah, it happened to me too. It seems a explorer.exe bug. After restarting the computer, the tray icon works fine. –  Leonel Martins Jul 31 '09 at 14:39
add comment

2 Answers

As far as I know this is a bug in Windows XP, you may get some improvement if you check all options except "minimize on use."

share|improve this answer
add comment

As an alternative, consider using Process Explorer (free, distributed by Microsoft) which replaces task manager (Options -> Replace Task Manager).

I've never had a problem with this disappearing off the taskbar, and it is much more detailed, and has tools to find locks on specific files, etc.


Re task manager: is this as simple as the auto-hide?

  • right-click on Start -> Properties -> Taskbar
  • look at "Hide inactive icons"; it is probably checked; click Customize...
  • find task manager and set it to "Always show"

However; I believe that the identification acts partly on the text, so it sometimes needs setting a few times...

share|improve this answer
    
No, that's not it. Auto-hide is turned off. I'm aware of PE, I have it installed, but it still bugs me that the built-in utility is broken and that I can't fix it. –  Jason Owen Jul 17 '09 at 8:55
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.