Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My laptop (14" Razer Bade) touch pad (Synaptics) has stopped working, but in a rather odd way. It started with the mouse pointer moving around erratically at times, a then it stared to freeze up for a short periods, then for longer periods, and after a restart it dose nothing. Well, the track pad part dose nothing, the buttons work fine.

However the erratic movements and freeze ups also effected USB mice (tried multiple mice, multiple USB ports), while the current situation only effects the touch pad, and other mice function normally (nothing wrong at all).

My first thoughts were too check the mouse settings, however I can not open the mouse properties in control panel, clicking on the icon defocuses the control panel window, but opens nothing. Furthermore the Synaptics touch pad icon that normally resides in the system tray is also missing.

My next step was too check the device manager, none of the "HID-complaint mouse" drivers appears to be for a Synaptics mouse, though there is a "Synaptics HID Device" in the Human Interface Device category.

The computer is less than a month old, so I don't see how the device could be worn out, and it's really weird that I can not open the mouse control panel item (I tried running sfc /scannow, it says it fixed something but it didn't fix the problem). It's also weird that it doesn't appear to show up in device manager, but the buttons still work, just not tracking.

And no, I don't think it's turned off, since there doesn't appear to be a way to do that.

share|improve this question

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.