Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have my Ubuntu Server, providing internet to home LAN. I want to connect DD-WRT router to my server in bridging mode, so wireless devices can get IP from server. Basically I want DD-WRT router to act like bridge. I read Wiki but still not clear. All I found is how to connect 2 routers to extend range, which isn't what I want.

So the question is how to configure DD-WRT in proper bridging mode?

share|improve this question
    
You may simply disable DHCP and use LAN port instead of WAN. –  week Nov 14 '13 at 8:54
    
This will not pass through the traffic. I have to set router into bridging mode. –  Pablo Nov 14 '13 at 8:56
    
Usualy Wlan and lan interfaces are bridged by default, so it should work. You may find out, if that is your case on Setup -> Networking in web interface. Why do you think it'll not pass the traffic? –  week Nov 14 '13 at 9:14
    
Why do you want to use a router at all? With hostapd, you can use your PC's wireless card to provide an AP to your wireless clients. That it automatically bridged with your ethernet connection, and you may save the money of a router, or use it elsewhere as a repeater, for instance. –  MariusMatutiae Nov 14 '13 at 9:28
    
@Marius Matutiae: I already have that router with DD-WRT with much better coverage than I could get with card Wi-Fi and I don't have wireless card. Also Wireless router is more mobile, can place anywhere near server... –  Pablo Nov 14 '13 at 9:43

1 Answer 1

Here is solution I came up with.

I changed mode to Router instead of Gateway

enter image description here

Then set router IP to my server's subnet IP and disabled DHCP.

enter image description here

At this point my wireless clients are able to get IP from server. Not sure if this is complete and perfect solution but one may use it.

share|improve this answer
    
Are you using the WAN-port at this moment? Then the "Router" setting is the correct one. See here (look at "Operating Mode"). If you would have used "Gateway" (which is default) you couldn't use the WAN-port because that one is "Natted". The other ports not. You could have used a LAN-port to the server in "Gateway" mode and DHCP disabled. But this setting is probably the best in this setup. –  Rik Nov 14 '13 at 13:34
    
@Rik No, I'm not using WAN port. It's acting like switch. I've updated first screenshot to show that I set Interface to Both. Not sure what is it, but looks like it is switching WAN to act like LAN. –  Pablo Nov 14 '13 at 13:38
1  
Here is an article to set the DD-WRT as "Wireless access point". Its setup is the same as yours except it doesn't mention the "Dynamic Routing" so i'm not sure you need to set it different then the default. It does mention other settings (like optional DNSMasq to Disable and disabling the firewall). You could check if these settings correspond with yours. The method we mentioned was the "Simple version" on that page. You could look at all the settings in the "Long version". –  Rik Nov 14 '13 at 13:56
    
@Rik Yes I've seen this article but it was mentioning Primary/Secondary routers so I thought it's for range extension. I only have 1 router. –  Pablo Nov 14 '13 at 15:03
    
Well... you could see your "Ubuntu Server" as a "router". It provides IP/DHCP and routing/NAT. So the DD-WRT wouldn't know any better as if it's a router or server. –  Rik Nov 14 '13 at 15:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.