Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have updated to Kubuntu 12.10 from 12.04 and my sound stopped working ... I think because of I have two soundcards in my system and I think that disabling one of them shouldsolve the problem. Here is the output of inxi:

$ inxi -Ax
Audio:     Card-1: NVIDIA GF106 High Definition Audio Controller
             driver: snd_hda_intel     bus-ID: 05:00.1
           Card-2: Advanced Micro Devices [AMD] nee ATI SBx00 Azalia (Intel HDA) 
             driver:     snd_hda_intel bus-ID: 00:14.2
           Sound: Advanced Linux Sound Architecture ver: 1.0.25
$ 

I want to disable the NVIDIA GF106 because it's HDMI output is not coming to my earphones. How do I do that? Or any other tips to get the sound back? Thanks a lot.

Here is the aplay -l output:

**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: ALC892 Analog [ALC892 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: SB [HDA ATI SB], device 1: ALC892 Digital [ALC892 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 7: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 8: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 9: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: Headset [Logitech USB Headset], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

and here is the ~/.asoundrc

pcm.!default {type hw card 0 device 0}
ctl.!default {type hw card 0 device 0}

and still not working :(

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

Perhaps your NVIDIA card is set as the default audio device; I have a similar issue when trying to get audio via HDMI in e.g. Flash. Problem is my Realtek card is set as default and some applications doesn't let you select which sound device to use. I solve the issue by setting my HDMI audio as default aduio device, which can be achieved by editing the .asoundrc file in your home directory.

Here's what to do. First you have to find the proper card and device you want to use. Run the command aplay -l. I'm guessing you want audio to come out your USB headphones? From the output of aplay -l you can see that the USB headphones is card number 2 and device number 0, so put the following in your .asoundrc file.

pcm.!default {
type hw
card 2
device 0
}

ctl.!default {
type hw
card 2
device 0
}
share|improve this answer
    
modified the question to include my output of aplay -l –  fritzone Nov 14 '13 at 12:23
    
Even after applying the changes it is not working :( –  fritzone Nov 14 '13 at 12:58
    
I'm guessing you want audio to come out your USB headset? (correct me if I'm wrong). From aplay -l you can see that the card number is 2 and device number is 0, so your .aoundrc should read pcm.!default { type hw card 2 device 0 } and ctl.!default { type hw card 2 device 0 }. And remeber to restart any application that you want to use the new default device. –  AcId Nov 14 '13 at 16:02
    
I've found it helpfull to have several .aoundrc.* files in my home dir. E.g. I have a file called .aoundrc.hdmi file so that I can just do a cp ~/.asoundrc.hdmi ~/.asoundrc whenever I want to set HDMI as the default device. –  AcId Nov 14 '13 at 16:06
    
I've edited my answer according to the information supplied from aplay -l. –  AcId Nov 14 '13 at 17:19
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.