Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I found a similar thread with someone saying he couldn't update on Windows 8.

I have the same issue here, but it started with Windows 8 not accepting my key after a restart. Now the Windows 8 I used was downloaded from the link in my receipt email, and the 8.1 from the Windows Store with normal procedures. It's the second time I clean installed them but the first time I did it through UEFI. Now after a reboot – as I mentioned – Windows says my key was for non core upgrade procedures and not clean install ones, so I followed another post on Microsoft's community, which said it was a common problem and you could solve it by changing the mediabootinstall DWORD 32 bit key value to zero and then slmgr -rearm in an elevated prompt.

Which I did and I was able to enter my key again, but now when I update I get the code 800f0922 on all updates – and I've already tried a clean boot but it didn't work.

So my problem is: I can't update and Windows doesn't accept my key. There is no chance my key got compromised or anything like that.

share|improve this question
1  
Have you tried to activate Windows by phone? Did you use the Windows Store to download and install the Windows 8.1 update? Please clarify your question. For instance you seem to have purchased Windows 8.1 when you already had a Windows 8 license which makes no sense. –  Ramhound Nov 14 '13 at 17:11
    
i purchased digitaly a copy of windows 8 and installed by clicking the link on my receipt email and downloading.After i did all the updates the windows 8.1 upgrade normaly turned up on the store wich i did! –  SnowMN Nov 14 '13 at 22:07
    
also windows 8 was installed through uefi and secure boot was not enabled i had the watermark on the bottom right corner but there was a fix in microsoft support site which removed it!the issue with the key appeared after i upgraded through windows store to 8.1 –  SnowMN Nov 14 '13 at 22:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.