Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I was using an 8GB microSD card with a Canon PowerShot SX150 IS camera. It was functioning correctly. One day when I took a picture, it prompted me: Memory Card Error. But I was able to display old photos. However it was taking an unexpectedly long time to display any photo, and was hanging after displaying 3-4 photos.

Today I made a backup of photos from my Windows 7 PC, and deleted them from the memory card. I also formatted the memory card fully. And my OS was displaying it empty. Now when I used the same card with my camera, it gives me the same error and shows me deleted photos.

If I read the memory card in my PC through the camera, it doesn't show me all photos. I am able to delete visible photos but I can't delete their folder. And next time when I again read the memory card, all the photos are there.

I believe my OS is failing in formatting the memory card or deleting photos from memory card.

What should I do?

Notes:

  • Other microSD cards are working fine in my camera.
  • Since it is a microSD card, there is no notch on the card to make it read-only.
share|improve this question

Try formatting it with/in the camera.

If that fails, be glad you didn't lose the old photos from it, and get it replaced if it's got a guarantee and doen't cost more to fulfill the guarantee than a new card would, or chuck it if it fails either condition.

I've had a brand new memory card fail on its first use, with 70+ pictures on it - I eventually got 20 or so of those off the thing. You were lucky to lose so little.

share|improve this answer
    
I have tried to format it through camera. But it fails. Any operation from camera takes too much time and result in fail. And I feel card is not damaged otherwise it should create problem with mobile and PC too. – Amit Gupta Nov 15 '13 at 8:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .