Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am having trouble with Eclipse 3.5 on Ubuntu. After I upgraded from Ubuntu 9.04 to 9.10 I have discovered that buttons with dialogue boxes no longer work correctly - nothing happens when clicking one.

This occurred only after the upgrade, so I'm guessing it's something to with the new Gnome or GTK libraries.

A bit more detail of my environment:

  • Ubuntu desktop 9.10 64bit
  • Compiz (nvidia) on dual screen
  • Java from package openjdk-6-jdk
  • Eclipse 3.5 from eclipse.org binary

I am able to use the keyboard to select/activate buttons as a temporary workaround, but I would appreciate a better solution.

share|improve this question

3 Answers 3

up vote 4 down vote accepted

It's apparently a known bug in Eclipse + Compiz that can be fixed by setting GDK_NATIVE_WINDOWS=true before running eclipse.

http://mou.me.uk/2009/10/31/fixing-eclipse-in-ubuntu-9-10-karmic-koala/

share|improve this answer
    
Thank-you! This work's nicely. –  Chris Harcourt Nov 10 '09 at 20:37
    
I have this bug and I'm not running compiz (running metcity). This does fix it however. What does that mean? –  Draemon Feb 14 '10 at 0:16

Try to deactivate Compiz and see if it helps, maybe it has problems with the dialog from Eclipse on your computer, and it makes them appear, but doesn't take mouse events after. (like an unfinished animation or something).

Edit: Ok, so Compiz is the problem, according to your comment. To make a smaller workaround, at first, maybe simply deactivate Compiz effects on small windows like dialogs, I remember there was such option. Maybe you can keep it for most windows, this way.

Other than that, besides trying to change parameters in Compiz, I don't have a better solution, for now.

share|improve this answer
    
Disabling Compiz does fix this - thank you. It's only a workaround, so I'm going to look for a better solution (I miss the scale plugin too much!). –  Chris Harcourt Nov 9 '09 at 15:59
    
It's not compiz. I had the same problem and I'm not running compiz –  Draemon Feb 14 '10 at 0:16
    
@Draemon - for Chris Harcourt, it was linked to Compiz. consider asking a new question, for yourself, referring eventually to this one, explaining your problem, and giving details about your configuration. This place is not a forum, it is a place for questions to be asked and answered. Check the FAQ (superuser.com/faq) for more information about this site. –  Gnoupi Feb 15 '10 at 8:29
1  
@Gnoupi: Just because disabling compiz fixed doesn't mean it's a compiz problem. My problem had exactly the same symptoms, and was fixed by exactly the same solution (GDK_NATIVE_WINDOWS=true). The root cause of the problem really isn't compiz, you've just found a second workaround that doesn't work as well as the GDK_NATIVE_WINDOWS=true one. When exactly did I say this was a forum? –  Draemon Feb 18 '10 at 16:06
1  
@Gnoupi I don't think you're paying attention. The accepted solution does solve my problem, and for that reason the analysis is just plain wrong. You might not care, but others might. My problem is solved. I am not treating this like a forum - just adding a comment pointing out flaws in the answers given to solve a certain problem. FYI I'm fully aware of how the site works. –  Draemon Feb 19 '10 at 16:26

I also have this issue. I don't have a fix, but you can click on a button and hit space/enter to activate it. You can use the keyboard for dialog boxes.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.