Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My internet speed as measured on speedtest.net is 10 Mbps from my desktop computer, which is connected via ethernet to the router. When I measure my speed from my laptop (Surface Pro) when on the WiFi network using the same router, however, the measured speed is 3 Mbps. In addition, when I'm transferring files over the wireless network, Windows 8 File Explorer reports the transfer rate to be 3 Mbps as well. When I test the network using my phone (Samsung Focus WP7), I get a speed of 7 Mbps.

Device Manager reports that the drivers for the card on the Surface Pro (Marvell AVASTAR 350N) are up-to-date. How can I get my Surface Pro speed to match the speed of my internet connection?

Here are my Wireless Router settings: Router Settings

Here are my Security settings on the router: Router Security Settings

share|improve this question
1  
This might be due to a lot of things. Can you see what your link-speed is on the laptop? You can try switching to 802.11g (instead of the 11b/g/n mixed mode). 11n is of no use for you with the limited internet speed and 11b is probably not used. Setting it to 11g might give you some stability (depending on the router). (it usually does for me) Also use a reliable (and different) speedtest because they can vary greatly. For example with some speedtest i get 5Mbps while i have 150Mbps. speedtest.net works nicely for me. They also have a mobile app (speedtest.net/mobile). –  Rik Nov 16 '13 at 15:04
    
@Rik, Using your advice, I changed the mode to 802.11g and I get my full 10 Mbps! Post as an answer below for some sweet points (: Also, the link speed on the laptop was 65.0 Mbps and I used speedtest.net to get the speeds (except for the phone, which doesn't have an app from speedtest.net). –  Ryan Shripat Nov 16 '13 at 16:02
    
I would strongly suggest changing your channel width to 20Mhz and your channel to 1, 7, or 11. Using partially overlapping channels just slows things down for everyone. –  David Schwartz Jun 25 '14 at 19:10

2 Answers 2

up vote 1 down vote accepted

Not getting the full speed on WiFi might be due to a lot of things.

You can check your link-speed. If it is not 54Mbps (but far below that) you might have a lot of interference in the air. But your phone has good speed so your laptop should be able to get the same.

You can try switching to 802.11g (instead of the 11b/g/n mixed mode). 802.11n is of no use for you with the limited internet speed and 802.11b is probably not used.

Setting it to 802.11g can give you some stability (depending on the router). (it usually does for me) When you do have a modern-modem you could try 802.11n only but if you see your link speed at 65Mbps with that mode it might be better to choose 802.11g for stability because your modem does not give you the full 802.11n speeds.

Also use a reliable (and several/different) speedtests because they can vary greatly. For example with some speedtest i get 5Mbps while i have 150Mbps. http://www.speedtest.net works nicely for me. They also have a mobile app (http://www.speedtest.net/mobile) so you can compare the phone speed to you laptop.

(The app for Windows Phone should be here, there is a link to the store on the mobile page mentioned above)

share|improve this answer
    
Changing the mode to 802.11g worked. Also, the speedtest.net app is for WP8 and I have WP7. –  Ryan Shripat Nov 18 '13 at 15:14

You need to use Command Prompt

Then do ipconfig /dnsflush, this will delete all of the cashe that is causing the internet to slow down a bit. Also you need to reset your router at least once a month and update it reguarly. Install the driver as it'll fasten a bit. Then make the IP 208.67.222.222 and then the ALT should be 208.67.220.200 to fasten up browsing speed and maybe game speed. All you need to do is go to Control Panel, then go to Network and Sharing center, then after go to Protocol V4, then click Properties, then click the second option on IP, then enter it. This lowers the chance of disconnection. Also delete all of your TEMP FILES by going to Run and then Type in %Temp% and delete them. The system files will not harm your computer. You're not gonna get all of them.

Hope this helps!

share|improve this answer
1  
Welcome to SO! If you answer a question that has already an accepted answer, make sure you add something that wasn't in the original answer. I do not see how this answer add anything to this specific question. Also try to explain why your solution work. –  Mixxiphoid Jun 25 '14 at 18:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.