Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a ASUS F402CA-WX102H notebook.

  • I disabled UEFI Secure Boot, booted on USB and installed Debian Wheezy (double boot with Windows8 for now).
  • The installation process worked fine, but the laptop random crashed both on Linux and Windows after a couple of minutes or less.
  • So I reinitialized the BIOS (hence re-enabling the Secure Boot): I can start W8 and it works fine, but of course can't boot on Debian.
  • If I disable again Secure boot, the problem is back.

Note:

  • I wouldn't mind deleting all windows & partitions, if it could help...
  • I could run all the Debian installation process well (something like an hour), so it seems, it's not merely a problem of running another OS in disabled mode that triggers the problem.
  • I don't know if I have to or if it even makes sense to run to this complicated process described for Ubuntu like there: http://askubuntu.com/questions/91484/how-to-boot-ubuntu-from-efi-uefi

Any help, any idea what could cause or what could disable these crashes?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

First, try upgrading your firmware. What you describe reeks of a firmware bug, so an update might fix it.

If that fails, you can try adding Secure Boot support for Debian. I haven't followed Debian's Secure Boot policies very closely, but it's certainly possible to add Secure Boot support for any Linux distribution. I've written two Web pages on the subject:

  • My generic Secure Boot page describes enabling Secure Boot in general terms. You probably want to follow the "Using a Signed Boot Loader" section. Unless Debian is now signing its GRUB binaries and kernels and you can find the Debian public key file, using PreLoader is likely to be a bit easier than using shim.
  • My rEFInd Secure Boot page describes using Secure Boot with rEFInd specifically. If you're not using rEFInd, this page is less likely to be useful than the first one, but you might still pick up a thing or two, so it might be worth skimming.

One more thought occurs to me: It could be that something about GRUB 2, and not Secure Boot, is causing the prooblems. When you enable Secure Boot, the firmware bypasses GRUB 2 and boots Windows via its own boot loader; but when you disable Secure Boot, the computer boots through GRUB 2. You could test this hypothesis by disabling Secure Boot and using the firmware's own boot manager or a USB flash drive or CD-R version of rEFInd to boot Windows without involving GRUB. If the problems go away, then that's strong evidence that GRUB is doing something weird. If that's the case, you should install another EFI boot manager. See this set of pages for a description of what's available. That said, I've never heard of this type of problem before, so it seems like a long-shot. Still, it's easy enough to test, and so is worth investigating -- maybe before trying to add Secure Boot support for booting Linux.

share|improve this answer
    
Thanks a lot for your answer. (Un)fortunately the answer is much easier, it was just an hardware defect, triggered mostly by a key stroke which I didn't used under windows and hence not recognized...maybe your post will help once the hardware defect recovered :) –  e-Mile Nov 21 '13 at 10:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.