Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an NSLU2 ("slug") network-attached storage box, running nslu2-linux, which was working well until I replaced some hardware in my home network. My current setup is very simple: I have a single box (Motorola SBG6580) which is a combination cable modem and wifi router. A couple of desktop machines, the NAS, and a Vonage box all hang off of this box. The slug is hardcoded to use IP address 192.168.1.77. The router assigns DHCP addresses in the 192.168.0.x range. I'm pretty ignorant about networking, but this actually seems like it should be OK: the hardcoded IP of the slug doesn't fall in the range that the router wants to be able to use for DHCP, so there would be no conflicts. However, I can no longer connect to the slug:

---- rintintin ~ $ ping 192.168.1.77
PING 192.168.1.77 (192.168.1.77) 56(84) bytes of data.
From 72.129.61.64 icmp_seq=1 Time to live exceeded
From 72.129.61.64 icmp_seq=2 Time to live exceeded
From 72.129.61.64 icmp_seq=3 Time to live exceeded
From 72.129.61.64 icmp_seq=4 Time to live exceeded
^C

Or:

---- rintintin ~ $ ssh root@192.168.1.77
ssh: connect to host 192.168.1.77 port 22: No route to host

Access to other stuff on the network is fine:

---- rintintin ~ $ ping 192.168.0.3
PING 192.168.0.3 (192.168.0.3) 56(84) bytes of data.
64 bytes from 192.168.0.3: icmp_req=1 ttl=64 time=0.144 ms
64 bytes from 192.168.0.3: icmp_req=2 ttl=64 time=0.095 ms
64 bytes from 192.168.0.3: icmp_req=3 ttl=64 time=0.096 ms
^C

I've clicked around in the router's big, complicated web interface, but haven't found any indications of what might be wrong. Maybe it's set by default to deny access to IP's that aren't of the form 192.168.0.x? Maybe it's set by default to deny access to IP's that aren't ones that it assigned via DHCP? How would one go about diagnosing and fixing this problem?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

There is a simpler, better solution to the problem correctly diagnosed by davidgo: change your network to 192.168.1.0/24, and leave the mask unaltered. Allo modern routers are configured to do that. In the following image,

enter image description here

you can see the line called Local IP address, where I can specify my network. I have chosen 192.168.11.1 for the router LAN address, and a mask 255.255.255.0, while you ought to choose the same mask, but the router address 192.168.1.0. This way you will have a smaller mask (there is no need in a SOHO for 65,536-strong subnets), and you will be able to talk to your NAS. You may have to re-boot your machines.

share|improve this answer
    
That worked, thanks! I couldn't set it to 192.168.1.0, got the error message "Make sure the Primary Network and Guest Networks do not overlap IP pools." I'm not clear on what a guest network is, but anyway guest network zero was 192.168.1.10 - 192.168.1.99, so I was able to set it to 192.168.1.100. –  Ben Crowell Nov 17 '13 at 16:31

Check the netmask of your systems. I suspect it is 255.255.255.0, meaning 192.168.0.X, when you really need a wider netmask, say 255.255.0.0, which means 192.168.X.X - It sounds to me like the NAS needs to be in the same network to work, as you don't appear to have a gateway configured to handle this.

Alternatively, reduce the number of IP addresses handed out by the DHCP server and renumber the NAS so that it is in 192.168.0.X but outside the range of IP's handled by the DHCP server.

share|improve this answer
    
Thanks for your answer. If I was going to change the subnet mask, which device would I change it on? The router? The router is the only thing that has changed between now and when the system used to work. The router's web interface doesn't seem to offer any way of changing it. (I tried doing "ifconfig eth0 netmask 255.255.0.0" on my desktop machine, and the result was that I lost all network access.) Unfortunately I can't reconfigure the NAS, because I can't ssh into it. –  Ben Crowell Nov 16 '13 at 22:42
    
I really need to know a lot more about your config - I'm not sure I can help without actually seeing it. Are you running DHCP on your network ? (If so, can you configure your DHCP server to hand out 255.255.0.0). What is the IP of your NAS ? (You may be able to change your DHCP range to 192.168.1.x and leave the NAS "as is") –  davidgo Nov 17 '13 at 4:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.