Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm not sure if this is a hardware problem or not, but in order to type the "<" character, I have to hold down shift+comma and then release shift before releasing comma. For all other keys, (!"£$%^^&*()?@~}{ etc..) I can just hold down shift and press the key I want to output.

This is VERY annoying when you're a Web Developer like me and need the "<" character all the time.

As per usual, I have updated the drivers and have ran a Windows Update and BIOS update. Nothing has helped.

Running Windows 8.1 (also not working in Ubuntu Live CD) on a i7 Processor, GT 650M, 8GB RAM Asus Laptop. I've contacted them and they're not sure what the problem is, and suggest I return it as it has a malfunctioning keyboard. If anyone has any other theories, that would be great!!

Does anyone know what it could be?

Much appreciation!

EDIT: Also, keyboard layout is correctly set to UK Layout.

share|improve this question
    
First try a USB keyboard and see if it works right. But if no other keys seem to malfunction and the keyboard is relatively new and has not had any liquids spilled on it then it's highly unlikely to be a hardware problem. There is a chance that this is one of the "sticky key" settings in the "Ease of Access Center" -- that annoying thing that pops up if you touch the shift key too many times. –  Daniel R Hicks Nov 17 '13 at 14:57
    
I have checked the ease of access control panel and turned everything off. It works with an external keyboard so I guess the problems lies within the laptop's hardware? –  Stefan Dunn Nov 17 '13 at 16:02
    
Seems unlikely that it would be laptop hardware, given that the hardware doesn't do any transformations of that sort. But I suppose it's vaguely possible that the shift and comma keys share an X or Y line and that that line is slightly flaky and is not handling multiple keypresses right. (Would expect to find a few other keys that fail similarly in that case, but it's hard to predict which ones, since the X-Y wiring is up to the manufacturer.) Do you get a comma if you do it "wrong", or no key at all? Have you tried shift and all the alpha keys? –  Daniel R Hicks Nov 17 '13 at 20:29
    
It works with a USB keyboard plugged in which is why I think its hardware fault. What do you think? –  Stefan Dunn Nov 18 '13 at 11:22
1  
Yeah, it's sounding like hardware. Unusual but certainly not impossible. –  Daniel R Hicks Nov 18 '13 at 22:03

1 Answer 1

Check your layouts. I had a "US" installed under "Hungarian" and it was totally messed up.
Ended up just removing every layout and installing what I needed. (Hungarian - Hungarian, and US - US.)

By the way some applications behaved really weird for me with Windows 8.1 and global layout switch, so you may also want to give that a shot. (There is an option to return to the application-specific layout switching at regional settings.)

share|improve this answer
    
See Original question, I have already checked the layout settings. –  Stefan Dunn Nov 17 '13 at 16:03
    
@StefanDunn: Did you check if it's not UK->US but US->US? –  Shiki Nov 17 '13 at 16:05
    
Its UK. The @ and " keys are correctly mapped –  Stefan Dunn Nov 17 '13 at 19:13
    
@StefanDunn - Might be worth changing the layout to US and seeing if the problem persists. –  Daniel R Hicks Nov 17 '13 at 20:33
    
It does :(. I've tried almost every combination of keyboard setup and accessibility to no provail. –  Stefan Dunn Nov 18 '13 at 12:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.