Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I enabled AHCI mode for SATA (and virtualisation) in my BIOS and rebooted to Windows 8. This failed, so I switched it back. I realise now that something like this is required to change to AHCI mode.

After switching back I am stuck at the "Please wait" screen forever. This happens after selecting Windows 8 from the graphical boot manager and before the login screen. Sometimes there seems to be a small amount of activity judging by the HDD light and sometimes quite a lot. However mostly very little. I've tried leaving it overnight and throughout the day with no progress seemingly being made. Suspend and resume work properly.

Using various advanced boot options has also made no progress: automatic repair fails, safe mode fails, command prompt succeeds but SFC fails. There is no pending.xml. I've also tried using DISM to remove any pending operations, which fails. I have no system restore point. I've tried automatic repair from the DVD also. I've tried re-enabling AHCI mode after following these instructions.

UPDATE: I have just found that booting straight to the Windows disk (BIOS order) gives an error about \Boot\BCD (code: 0xc000000f) being missing or corrupted. Not convinced this is the case, as normally (via GRUB) the bootmgr is functional. Appears to be boot disk ordering issue, having used bcdboot to force boot files onto the drive, it boots again to "Please wait".

This is a multi-boot machine. The Windows XP installation and Ubuntu still work fine.

I would really prefer not to lose all applications and settings with a refresh install. Is there any way to debug this issue further?

UPDATE: out of desperation - and after several more hours trying fail-safe BIOS settings, DISM variations etc. - I tried the "Refresh your PC" option. It also fails with message "There was a problem refreshing your PC". It appears that Windows 8 provides absolutely no information whatsoever about what is wrong, and none of the supplied tools function properly to recover.

share|improve this question
    
Try using the F8 options with Win8. Otherwise you are pretty much stuck. I would resize my partitions to get all the disk space I just can, or use Crashplan. And there goes the reinstall. –  Shiki Nov 17 '13 at 16:15
    
As above, the advanced boot options have been no help thus far (and F8 does not work on Win8). I'm looking for something like a more verbose boot or log file to find out how to target repairs. I would not expect it to fail after switching back to IDE compatible mode. –  Sam Brightman Nov 17 '13 at 16:26
    
"Would not expect it to fail." It's next-gen, son. Step it up. Those weather tiles are centuries ahead of our time. Even Shift+F8 fails? (I read that you only have a very small window to press it though.) –  Shiki Nov 17 '13 at 16:36
    
Shift-F8 fails, but that isn't important. I can get to the advanced options and they do not help. –  Sam Brightman Nov 17 '13 at 17:23
add comment

1 Answer 1

This bug/error can be circumvented by simply rotating your screen. Most likely your system is working 100% correct behind the "please wait" screen. What you need is to be able to launch the Task Manager and kill the process responsible.

Do the following steps:

  1. Hit Ctrl+Alt+ to rotate the screen 90 degrees, making the display area narrow.
  2. Restart.
  3. Hit Ctrl+Alt+ to return the screen orientation to normal. The "please wait" screen will now ocuppy only half of the screen size. You can now launch the Task Manager and operate it. I don't remember the name of the process (OptIn or something) but you will find it without doubt.

In case the Task Manager launches, but is entirely covered by the gray screen, do this:

  1. Make it active using Alt+Tab.
  2. Hit Alt+Space to bring up the window menu.
  3. Hit 4 times and then Enter to maximize Task Manager so that you can use it.
share|improve this answer
1  
There is no such shortcut such as Ctrl-Alt-←. –  kinokijuf Apr 13 at 21:40
    
I remember some onboard Intel graphics do enable such shortcuts, but this seems sketchy... –  Doktoro Reichard Apr 13 at 21:47
    
Ah, apparently the screen-rotation shortcuts are available with nVidia cards. –  TheFutureBlues Apr 13 at 21:52
    
I have an ATI card. I think the keys are available but not by default. Any ideas on how to test this without hotkeys? This sounds like it happens after the login screen, which I cannot reach. –  Sam Brightman Apr 15 at 5:45
    
I read somewhere else that you can connect an external monitor, thus extending the desktop a little to be able to use the task manager... –  TheFutureBlues Apr 15 at 10:31
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.