Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed ActiveMQ on Ubuntu using the command sudo apt-get install activemq which seemed to work fine.

Then, I activated a configuration by copying the sample configuration provided with the installation with this command:

sudo ln -s /etc/activemq/instances-available/main /etc/activemq/instances-enabled/main

And then I started the broker: sudo service activemq start

Which seemed to work since it returned an OK and no errors.

I can see it is started and listening to port 61616:

administrator@ci-server:~/tmp/Codebase/Build/$ netstat -an | grep 61616
tcp6       0      0         :::*                    LISTEN     

Also, if I start it in debug mode, I can see it runs fine:

administrator@ci-server:~/tmp/Codebase/Build/$ sudo /etc/init.d/activemq console main
 * Starting with Console ActiveMQ instance  main                                                                                   INFO: Loading '/usr/share/activemq/activemq-options'
INFO: Using java '/usr/lib/jvm/java-7-openjdk-amd64/bin/java'
INFO: Starting in foreground, this is just for debugging purposes (stop process by pressing CTRL+C)
Java Runtime: Oracle Corporation 1.7.0_25 /usr/lib/jvm/java-7-openjdk-amd64/jre
  Heap sizes: current=126720k  free=123924k  max=253440k
    JVM args: -Xms128M -Xmx256M -Dorg.apache.activemq.UseDedicatedTaskRunner=true -Dactivemq.classpath=/var/lib/activemq/main/conf;/etc/activemq/instances-enabled/main; -Dactivemq.home=/usr/share/activemq -Dactivemq.base=/var/lib/activemq/main
ACTIVEMQ_HOME: /usr/share/activemq
ACTIVEMQ_BASE: /var/lib/activemq/main
Loading message broker from: xbean:activemq.xml
 INFO | Refreshing org.apache.activemq.xbean.XBeanBrokerFactory$1@44edb080: startup date [Sun Nov 17 16:03:30 PST 2013]; root of context hierarchy
 INFO | PListStore:/var/lib/activemq/main/data/localhost/tmp_storage started
 INFO | Using Persistence Adapter: KahaDBPersistenceAdapter[/var/lib/activemq/main/data/kahadb]
 INFO | JMX consoles can connect to service:jmx:rmi:///jndi/rmi://localhost:1099/jmxrmi
 INFO | KahaDB is version 3
 INFO | Recovering from the journal ...
 INFO | Recovery replayed 1 operations from the journal in 0.029 seconds.
 INFO | ActiveMQ 5.5.0 JMS Message Broker (localhost) is starting
 INFO | For help or more information please see:
 INFO | Listening for connections at: tcp://localhost:61616
 INFO | Connector openwire Started
 INFO | ActiveMQ JMS Message Broker (localhost, ID:ci-server-47748-1384733012178-0:1) started

The problem is, when I run activemq status, it displays the following message:

administrator@ci-server:~/tmp/Codebase/Build/$ activemq status
INFO: Loading '/usr/share/activemq/activemq-options'
INFO: Using java '/usr/lib/jvm/java-7-openjdk-amd64/bin/java'
ActiveMQ not running

I have a script that checks for the output of this command, and it is failing on this because it expects the output to say that it is running... I can't change that script.

Anyone knows why could this be?

Any ideas on why would ActiveMQ report Not Running when it seems to be running would be greatly appreciated! I don't know what else to check...

Thank you very much!!


share|improve this question

I'm just fumbling my way through ActiveMQ on Debian Wheezy. I couldn't understand what was happening with the apt-get install version either...

I have it running though. I finally went with wget. I create an activemq user, and as this user, I run: wget

When I untar, cd apache-activemq-5.10-SNAPSHOT then I run ./bin/activemq start.

There's lots more to learn, but I've gotten that far.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.