Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Immediately after installing Office 97, I am no longer able to change the UAC level setting in the "User account control settings" dialog.

I can move the slider bar to a different level up or down but there is no response whatsoever when the ok button is clicked. After un-installing Office 97 completely (I also used eraser97.exe after the normal uninstall process to ensure that it was competely removed), the "User account control settings" dialog no longer even appears when clicking on the "Change user account control settings" link from the Action center.

From the research that I have done so far it seems that this is a common issue with people needing to use Office 97 and it may have something to do with a conflict between the macro protection system in Office 97 and the UAC implementation within Windows 7.

It is still possible to change the UAC settings by making changes directly within the registry but this is less than ideal and shouldn't have to be necessary. I am always logged on as an Administrator and have tried this on 4 seperate computers with exactly the same result. Please note that I am not able in this case to upgrade to a later version of office. I am using only Access from Office 97 and this contains a particular feature that is absolutely necessary for me, that later versions of Access don't have.

I fully understand that Office 97 is no longer supported by Microsoft, but I think that this is irrelevant in this case, as this is a Windows 7 bug when installing software that works correctly on Windows XP. Windows 7 should continue to work satisfactorily whether Office 97 is installed or not, just like any other legacy application. This is particulary true of core aspects such as the UAC.

We have already considered using the Windows 7 XP mode, but due to it's many limitations, this is not a suitable solution for most of the systems we need to install onto.

Note: Other than this issue Access 97 seems to work without problems on Windows 7.

I would be grateful for some assistance with this issue.

share|improve this question
2  
Perhaps this is God's way of telling you it's time to get off legacy DBs from 12 years ago? I'd migrate asap. –  phoebus Nov 9 '09 at 1:24
    
Alternatively, you could just stick with XP. –  phoebus Nov 9 '09 at 1:29
    
@ phoebus: God's on vacation, Lloyd Blankfein's doing His work :) –  Molly7244 Nov 10 '09 at 0:55

1 Answer 1

up vote 3 down vote accepted

We have now worked out what the specific cause of this problem is.

Office 97 makes many changes to the Windows registry when it is installed. This is to be expected of course.

Unfortunately it changes some existing values in specific registry keys which are the cause of the issue. The changes were appropriate for older versions of windows but definitely not for Windows 7.

What has worked for us is to back-up specific registry key values, install Office 97 and then restore these values.

In each case it is the default value of the key that needs to be restored.

The keys in question are:

HKEY_CLASSES_ROOT\Interface\{B722BCC5-4E68-101B-A2BC-00AA00404770}
HKEY_CLASSES_ROOT\Interface\{B722BCC5-4E68-101B-A2BC-00AA00404770}\NumMethods
HKEY_CLASSES_ROOT\Interface\{B722BCC5-4E68-101B-A2BC-00AA00404770}\ProxyStubClsid32

HKEY_CLASSES_ROOT\Interface\{B722BCC6-4E68-101B-A2BC-00AA00404770}
HKEY_CLASSES_ROOT\Interface\{B722BCC6-4E68-101B-A2BC-00AA00404770}\NumMethods
HKEY_CLASSES_ROOT\Interface\{B722BCC6-4E68-101B-A2BC-00AA00404770}\ProxyStubClsid32

HKEY_CLASSES_ROOT\Interface\{B722BCC7-4E68-101B-A2BC-00AA00404770}
HKEY_CLASSES_ROOT\Interface\{B722BCC7-4E68-101B-A2BC-00AA00404770}\NumMethods
HKEY_CLASSES_ROOT\Interface\{B722BCC7-4E68-101B-A2BC-00AA00404770}\ProxyStubClsid32

HKEY_CLASSES_ROOT\Interface\{B722BCC8-4E68-101B-A2BC-00AA00404770}
HKEY_CLASSES_ROOT\Interface\{B722BCC8-4E68-101B-A2BC-00AA00404770}\NumMethods
HKEY_CLASSES_ROOT\Interface\{B722BCC8-4E68-101B-A2BC-00AA00404770}\ProxyStubClsid32

HKEY_CLASSES_ROOT\Interface\{B722BCC9-4E68-101B-A2BC-00AA00404770}\NumMethods
HKEY_CLASSES_ROOT\Interface\{B722BCC9-4E68-101B-A2BC-00AA00404770}\ProxyStubClsid32

HKEY_CLASSES_ROOT\Interface\{B722BCCA-4E68-101B-A2BC-00AA00404770}\NumMethods
HKEY_CLASSES_ROOT\Interface\{B722BCCA-4E68-101B-A2BC-00AA00404770}\ProxyStubClsid32

HKEY_CLASSES_ROOT\Interface\{B722BCCB-4E68-101B-A2BC-00AA00404770}
HKEY_CLASSES_ROOT\Interface\{B722BCCB-4E68-101B-A2BC-00AA00404770}\NumMethods
HKEY_CLASSES_ROOT\Interface\{B722BCCB-4E68-101B-A2BC-00AA00404770}\ProxyStubClsid32

Restoring the original default values of the last 3 keys shown above will in fact by itself restore the normal operation of the UAC settings user interface, but as the other keys are all closely related they should as a matter of course be restored also.

share|improve this answer
    
This works. Thanks. I copied the original values for these keys from another copy of Windows 7 that had never had Office 97 installed. The UAC user level setting dialog now works again. This makes sense. There is no way that Office 97 can possibly be installing anything to implement these interfaces that is more recent than what Windows 7 already has. So it should not be changing these registry entries anyway. There must be a bug in the installer that allows this to happen. Interestingly, on my WinXP systems, the Office 97 installation does not seem to have made these changes. Go figure! –  Neville Cook Nov 20 '09 at 11:49
    
Microsoft have finally acknowledged that this is a problem, and have provide a solution (support.microsoft.com/kb/978591) - which is an exact copy of this solution. Good work. –  Neville Cook Jan 12 '10 at 23:22
    
The Microsoft solution seems to have confirmed something that we could not previously know for sure - that the values for each of these registry keys are common enough across all users to be able to just use fixed values rather than first having to save the values from your system. They have provided the text for a full registry file that fixed the problem. –  Neville Cook Jan 12 '10 at 23:30
    
From a comment posted as an answer: "The above registry changes also fix two other issues. The first is an issue in Internet Explorer where one cannot right-click the Tabs bar to bring up a context menu. This is particularly bothersome in IE9 (and later?) because the Menu bar and Favorites bar are disable by default. The context menu enables you to restore them. The second is an issue in Windows Live Mail 2012 where the print function does not work. When the registry changes were applied, printing was restored." –  gronostaj Jul 23 at 15:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.