Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

For the life of me, I can't figure this out. I had it working once in my network, but never after that.

I have two machines A (Win7-x64) and B (WinXP-x86), connected through TP-Link's TL-MR3420 Router (wired connections). Computer A has an EVDO device connected directly in a USB port and is connected to the Internet. Now I want to share this connection with machine B. Can anyone tell me exactly what configuration would work?

  1. Do I need to run DHCP on both the router and the EVDO device? If yes, what ranges should I assign?
  2. Do I need to assign static or automatic IPs on both EVDO and router connections on both machines? If static, exactly what IPs would work?
  3. Both the router and the EVDO device need to have an IP assigned to themselves too. What should be assigned there?
  4. Do I need to enable ICS?

I have literally tried dozens of combinations of the above without success. In some cases, I can even see the EVDO connection in the taskbar area of machine B, but it never browses the Internet.

Thank you.

share|improve this question
add comment

3 Answers

up vote 0 down vote accepted

Finally, finally...

For anyone else banging their head with it, here are the settings that work for me. You do not need ICS for this. Just bridge your EVDO and LAN connection on the host machine. Use the following settings:

CLIENT COMPUTERS

IP:     Auto
DNS:    Auto
IE > Tools > Internet Options > Connection > LAN Settings > All boxes should be clear

HOST COMPUTER

LAN Connection
--------------
    IP:     Auto
    DNS:    Auto

EVDO Connection
--------------
    IP:     Auto
    DNS:    Auto

* Bridge the above two connections

EVDO

IP:         192.168.1.1 / 255.255.255.0
DHCP:       Enabled / 192.168.1.121-140

ROUTER

IP:         192.168.1.2 / 255.255.255.0
DHCP:       Enabled / 192.168.1.100-199
Gateway:    192.168.1.1 (IP of EVDO)
Pri. DNS:   192.168.1.121 (IP of Host machine)
Sec. DNS:   8.8.8.8 (Google DNS Server)

The above works for me, but I'm not a networking expert by any stretch. So if anyone finds out there is something that should be different, plz share.

share|improve this answer
add comment

A couple of things you should look at to avoid weird sh*t in future....

Unless the host machine is running a local DNS server I would point your router to use either the EVDO (if it supports DNS hosting) or an external DNS (like you have done with 8.8.8.8) as your primary DNS server. I often use 8.8.8.8 and 8.8.4.4 as my DNS entries.

I'm guessing the client machines are probably going to use the router as their DNS server anyway so the only purpose of the routers DNS requests are to get internet addresses, google servers can provide these more reliably than your host machine can.

Having 2 DHCP servers on the same subnet is also not a great idea. Disable it on the router and see if you can still connect to the net from the client machines. If not, at least change the DHCP ranges so they don't overlap.

eg

EVDO DHCP:

192.168.1.100-150

Router DHCP

192.168.1.151-254
share|improve this answer
    
Thanks Chris. I'll try the first one. The second one however doesn't appear to have worked in the past. As soon as I disable DHCP on either the router and/or the EVDO device and restart, I can no longer access them. Not sure why. –  dotNET Nov 18 '13 at 11:11
    
Fair enough. Without the EVDO DHCP you probably would need the IP set to static. If it were me, I'd have both it and the LAN IP on the host static anyway, with the DNS hardcoded in. That's just the way I like it for anything that acts as a host @dotNET –  Chris Nov 18 '13 at 12:39
add comment

ICS? why do you need a computer running to use internet on the other. Simple solution, attach your EVDO device to the TP-link router directly, configure the router to run under CDMA/EVDO mode. I'm sure this router model does support EVDO.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.