Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a problem. My notebook has two graphics card and one among them is not supported by NVidia now. When the new drivers are installed my notebook will not boot any more. I tried to delete drivers and to disable this device.

Everything will be ok, but in some time Windows without asking installs driver for this graphic card and then enables it. As the result on the next I have a brick as Windows do not boot. I have to boot in safe mode and disable remove driver, disable device.

My question is how to tell this "piece of software" to forbid automatic driver installation for this graphic card.

  • Notebook: Asus UL30Jt
  • First graphic card: Intel HD2000 (works well)
  • Second graphic card: NVIDIA GeForce 310M (problems)
share|improve this question
1  
Can you disable switchable graphics in the BIOS? Why not just disable the device instead of removing the driver AND disabling it? editing your question and including your exact make/model of notebook and graphics adapter(s) may help as well. –  techie007 Nov 18 '13 at 16:55
    
When I do so my notebook works in 1024x768 mode and do not see both the first and the second graphic card. –  Seagull Nov 18 '13 at 16:56
    
When you do which? –  techie007 Nov 18 '13 at 16:58
    
When I turn off switchable graphics in the BIOS my notebook starts working in 1024x768 mode. Added model info. –  Seagull Nov 18 '13 at 17:00
    
Ok, you are quite confusing. If you want to disable nVidia, that why do you wan't to see it... you cannot use it anyway. Second, considering that you didn't provide us with the at least make/model you are preventing us to offer you any viable solution. We can just guess what this could be –  Nikola Dimitrijevic Nov 18 '13 at 17:02
show 5 more comments

1 Answer

up vote 1 down vote accepted

Dirty fix (after you have uninstalled the existing driver):

  1. Bring up the control panel in desktop mode (WINDOWS KEY + X , Control Panel)
  2. Type the letter "U" in the search bar
  3. Choose Windows Updates
  4. Choose Check for updates
  5. Find the driver to install and right click on it.
  6. Choose Hide update.

This should prevent windows from trying to reinstall it.

This is not exactly how I would fix this problem myself, I would be more inclined to get the drivers installed correctly, but it does answer your question.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.