Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an Ubuntu 12.04 box with two "Intel Corporation I350 Gigabit" ports. These work fine with my cable modem at 1Gbps speed. I tried to have my old Linksys wrt54g router in between. The wireless connection to the router works fine, but I cannot get the Ubuntu box to connect to the router. I tried few cables, but it seems the problem is with the configuration on the Ubuntu box.

Right after the cable is plugged in the port light changes from amber to green. Also ethtool shows that link has changed to 100mbps.

Settings for eth0:
    Supported ports: [ TP ]
    Supported link modes:   10baseT/Half 10baseT/Full 
                            100baseT/Half 100baseT/Full 
                            1000baseT/Full 
    Supported pause frame use: No
    Supports auto-negotiation: Yes
    Advertised link modes:  100baseT/Full 
    Advertised pause frame use: Symmetric
    Advertised auto-negotiation: Yes
    Speed: 100Mb/s
    Duplex: Full
    Port: Twisted Pair
    PHYAD: 1
    Transceiver: internal
    Auto-negotiation: on
    MDI-X: Unknown
    Supports Wake-on: pumbg
    Wake-on: d
    Current message level: 0x00000007 (7)
                           drv probe link
    Link detected: yes

Also ifconfig shows some packets going both ways at the link level (TX and RX numbers). However I cannot ping the router or connect to internet. ping gives "No network found".

Anything else I can check?

Thanks!

share|improve this question
    
disable ufw, if installed and monitor outgoing packets using ngrep or tcpdump –  pylover Nov 19 '13 at 4:18
    
is the ip configuration valid for your network? is it perhaps using a 169.254 address? –  Frank Thomas Nov 19 '13 at 4:33
    
@plyover: ufw was inactive. Packet monitoring was a good idea. But I tried a router reset and for some reason it worked. –  Jeevaka Nov 20 '13 at 1:46
    
@Frank: Both the machine and the router were set to DHCP. –  Jeevaka Nov 20 '13 at 1:47
    
I disconnected power and use the router's reset button to clear the configuration. The connection worked after that. Previously I had this router set up as a secondary (cascaded) router connected to gigabit speed upstream router. Not sure exactly what was causing the problem. –  Jeevaka Nov 20 '13 at 1:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.