Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I created a 200GB TrueCrypt container, and thinking that you should be able to mount it from anywhere, I transfered it to my external hard drive. Then I tried to mount it, but TrueCrypt won't even display my external hard drive in the folder list. However I did notice a "select device" button. That to me seems like TrueCrypt wants to treat the whole hard drive as a container. Am I correct in saying that?

If so, then I have to move all the other files I have backed up in there to some other storage device(s). This is getting to be ridiculous. I love TrueCrypt, but it is starting to get annoying and hard to work with.

share|improve this question
    
what OS are you on, and can you see and open the external drive in your file manager? –  Frank Thomas Nov 19 '13 at 14:40
    
I am using Linux Fedora Gnome –  user270603 Nov 19 '13 at 14:51
    
is your external drive mounted at the time you attempt to mount your volume with truecrypt, and does your user have access to the location its mounted to? –  Frank Thomas Nov 19 '13 at 14:52
    
Yes, it was mounted and I transfered the container file, which took me 1 hour and 30 minutes. –  user270603 Nov 19 '13 at 14:54

1 Answer 1

up vote 1 down vote accepted

Yes you can mount truecrypt volumes and devices from external media, or even over remote file share in linux or windows.

the "Select Device" options are for encrypted partitions, not file volumes, as you have surmised.

Make sure you can view your volume file in your hosts file manager. if not the issue is your OS not the volume. you may need to touch the drive before it will appear to truecrypt.

are you able to mount the volume from the command line? since you are on fedora, you have realcrypt. Create a folder in your home to mount the truecrypt volume in, and run

realcrypt PathToVolume PathToMountVolume
share|improve this answer
    
Frank, Truecrypt is working fine as long as you have the container file in the system, but I want to be able to mount the container file from external device. –  user270603 Nov 19 '13 at 14:58
    
yes I know. have you tried mounting via the command line while its on the external disk? –  Frank Thomas Nov 19 '13 at 14:59
    
I have never mounted it via command line. I always used the GUI to create and mount container file, I although I did have to use command line to change the owner of my container file recently. –  user270603 Nov 19 '13 at 15:10
    
If this can't be done, then one will have to transfer the container file into the system. Then, load it with the files you want to "truecrypt" and once again transfer it back into the external hardrive. –  user270603 Nov 19 '13 at 15:19
    
please try it from the command line. that will tell you if you have a fedora/gnome issue, or a truecrypt issue, and hopefully give you hints about what to fix. I understand you usually use the gui and thats fine, but I am asking you to try the cli once and let us know if it worked. –  Frank Thomas Nov 19 '13 at 15:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.