Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using xubuntu 13.10. When I installed the system the fn keys for brightness worked, but somehow they aren't now. They stopped working with no reason.

The problem is that the keys are not even recognized. When I start showkey --scancodes in virtual terminal and try the brightness combination FN+left/right arrow the scancodes wont show, but for the volume (for example) it shows the scancodes right.

Anybody has any idea how to fix this.

I was googling for several days now and I can tell you that nothing solved my issue so far. Answer like setting acpi_backlight=vendor, or acpi_osi to something didn't work so don't post that. I also wanted to map those key to a script that would change ma brightness (I already made that script and it works) but I just can not get the keys to be recognized.

Thanks

share|improve this question

1 Answer 1

Well after some indeep testing I finally figured it out

The problem is with acer-wmi module, if this module is loaded, the key FN+left/right is not exposed to the user.

So I have blacklisted the acer-wmi module and now(so far), everything works, even better, with the acer-wmi blacklisted I get lower CPU temperature (~5C) and also better battery life, which is great

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.