Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to run a .run file, I log in as SU and run the following command:

sh xampp-linux-x64-1.8.3-1-installer.run

but I am getting the following error:

 Syntax error: Unterminated quoted string

What is the cause of this?

share|improve this question
    
The cause is stated (Syntax Error). Are you more interested in how to fix it? If so, is it plain text (can you cat *.run)? –  nerdwaller Nov 20 '13 at 15:00
    
The output is just gibberish. –  Colin747 Nov 20 '13 at 15:03

4 Answers 4

up vote 4 down vote accepted

The cause is probably an unterminated quoted string in the installer. (well duh!).

Either run it with the -x option to get more debug information, or open the installer in an editor and look for unmatched pairs of quotes.

Example:

#!/usr/bin/env bash
#My demo installer!
#
echo "starting here!"
echo "and an error in this line
echo "We will never get here!"

Notice the missing closing quote (") in the second echo line.


Edit:

I just downloaded a file called xampp-linux-x64-1.8.3-1-installer.run from sourceforge (which I assume is the same file as you are using) and when I opened it in vim I noticed it starts with ^?ELF^. This file seems to be an ELF binary.

Using the file command on it confirms this:
file: ELF 32-bit LSB executable, Intel 80386, version 1 (GNU/Linux), statically linked, stripped

It is not a shell script and the normal way to execute it would either be:

  1. xampp-linux-x64-1.8.3-1-installer.run (assuming the directory is in your search path),
  2. or with the full path prepended. E.g. ./xampp-linux-x64-1.8.3-1-installer.run if you are already in the same directory where the file is. (This is why @erhun's answer worked).
share|improve this answer
    
I'll take a look, I assumed it being a "offical" download that it wouldn't have any errors in it hence why I assumed it was something I'd done wrong. –  Colin747 Nov 20 '13 at 15:01
    
The next problem is I can't open the file, either with an editor (inc Vi) or even cat the file. Any ideas? –  Colin747 Nov 20 '13 at 15:03

It will work with this way.

chmod +x xampp-linux-x64-1.8.3-1-installer.run
./xampp-linux-x64-1.8.3-1-installer.run
share|improve this answer
    
That worked as a work around. –  Colin747 Nov 20 '13 at 15:56

I tried to install xampp-linux-x64-1.8.3-2-installer.run and had the same message. None of these answers worked for me because I think this is the x64 bit version and I was trying to install it on a 32bit Linux Mint.

Instead I downloaded xampp-linux-1.8.3-2-installer.run (notice the lack of x64 in the file name) and this one worked. I did the chmod , then sudo ./xampp-linux-1.8.3-2-installer.run and after good few seconds i had the gui installer running.

PS. You'll need to go to sourceforge because apachefriends.org website will give you x64 version as default download.

share|improve this answer

Looks not a problem with 64-bit OS.

I got same error and 'uname -m' can confirm it (displays x86_64), although I was already sure specifically purchase 64-bit machine.

Looks like while downloading (wget for many hours, very slow mobile Internet), 'xampp-linux-x64-1.8.3-4-installer.run' got corrupted!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.