Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Lenovo y580 laptop with a Broadcom wireless card which i bought about a year ago, now I have windows 8.1 on it, and my Wifi is completely unpredictable. My laptop worked well with win8 after I installed he official lenovo drivers, but became unpredictable after I installed 8.1 preview. Now I use the official 8.1 which also came with built in drivers, and the issues are still present. These issues are:

  • Random disconnects from the wireless network (I mostly see this when I play online which contantly uses the connection)
  • Not being able to connect to the wireless network, though the password is correct (to both WPA2-PSK network and an open, mac restricted network (I don't know the exact specifications about this, since this is my universitys network))
  • The Networks panel shows the connected status, but the connection is limited, or no internet access
  • The panel shows the connected status, but if I hover above it, it says unidentified network.

The only temporary solution I found for these problems are restarts. I don't know how and why (though I guess win 8.1 doesn't load up the driver, or loads up the wrong driver) the restart solves it, but after it (or sometimes 4-5) the wifi works until I turn it off, or put it into sleep. Sometimes the wifi will still work after a shutdown, but this is quite random.

Another interesting phenomenon when my wifi is not working is that the wifi adapter in the network and sharing center (and also the icon on the taskbar) shows this sequence: icon for no network connection(networking device disabled), wifi disabled, wifi waiting for connections.

I've read many posts regarding windows 8.1 and wifi issues, though I didn't find anything that fixed my problem. I tried updating it from device manager, disabling it and installing the Windows 8 driver (since on the Lenovo site, there are no Broadcom drivers for windows 8.1, saying it is built in), experimenting with other Broadcom 802.11 drivers, disabling power saving for the Wifi, disabling Ipv6, disabling wifi power saving in the power management settings. I'm quite sure the problem is software based, since it worked well with windows 8, and as far as i remember with windows 7 (also worked mostly with linux when I experimented with it though i had some trouble with it).

Any suggestion is valued, if you need any more information about the case, I will try to provide it ASAP. Thanks for your help.

share|improve this question

2 Answers 2

I have exactly the same problem with my Y580 which runs on windows 8.1

If you have installed the Intel PROSet/Wireless driver try to uninstall it, because Windows 8.1 has already included the driver. See this: http://support.lenovo.com/en_US/downloads/detail.page?DocID=DS037973

share|improve this answer

Use the Broadcom driver for Windows 8, instead of the integrated one that comes with Windows 8.1. Personally, this has worked for me in the past.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.