Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My goal is to access my NAS from a PC, but NAS is not reachable.

Situation

Here is my network configuration:

Router 1: 192.168.2.1 : 255.255.255.0

Router 2: 192.168.1.1 : 255.255.255.0

NAS: 192.168.1.108 (in Network of Router 2)

PC Foo: 192.168.2.xy

Problem

So problem is that I can't get access from "PC Foo" (no Ping possible) to my NAS. All other PCs with IP 192.168.2.xy get access.

Questions

I'm not sure but is this a subneting-problem?

What can I do to get access, when I don't want to change the IPs?

share|improve this question

migrated from serverfault.com Nov 20 '13 at 21:41

This question came from our site for professional system and network administrators.

    
So all your devices can communicate across both networks except the NAS? Do you have the correct default gateway set on the NAS? –  jlehtinen Nov 20 '13 at 16:03
    
@jlehtinen: "communicate across": I haven't try this, but I suppose no. –  Micha Nov 20 '13 at 16:08
    
How are the two networks physically connected? –  Zoredache Nov 20 '13 at 16:28
    
@Zoredache: Router 2 is connected to Router 1 via LAN-cabel. PC Foo is connected via WLAN to Router 1. NAS via switch with oder PC to Router 2. –  Micha Nov 20 '13 at 16:38
    
1) Arg. Confuzling post with LAN1 in 192.168.2 and LAN1 in 192.168.1.0/24. That really threw me in a loop. 2) Useful background reading: this post on our sister site. 3) All other PCs... where are these other PCs connected to? –  Hennes Nov 20 '13 at 22:00

2 Answers 2

up vote 1 down vote accepted

You need to set static routes in each router for the other router's network and make sure packet forwarding is enabled.

share|improve this answer
    
Thanks for answer (+1 for that). That is what I supposed. Problem is I can't find how to set this in Router 1. It is very stupid router provides by my provider. Are there any synonyms for "static routes"? –  Micha Nov 20 '13 at 16:11

I'm guessing you have router 2 doing NAT when it doesn't need to be. Disable NAT and DHCP service in router 2, to make it just act like an Ethernet switch/bridge. Then your whole network will be all one subnet, which is probably a better setup for you anyway.

If you have a good reason for router 2 to be doing NAT, then you'll need to enter NAT port mappings into it so anything on router 1's network can get to things they need to get to on router 2's network. You'll also need to set a static route on router 1 so it knows to send all 192.168.1.x traffic to router 2, or you'll need to set that kind of static route on all machines on router 1's network.

share|improve this answer
    
Thanks for answer (+1 for that). I will try this. Dividing the subnets has more are "organizational" reasons, but if can't setup the static route I will consider to create "one subnet". –  Micha Nov 21 '13 at 6:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.