Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Any changes I make in msconfig or Autoruns to remove items from startup seems to work without error in those two programs.

However, after the reboot, the startup items I disabled are back again, starting just after login.

share|improve this question
2  
This a personal or workstation? –  Ramhound Nov 21 '13 at 11:03
    
A personal workstation. –  Steve Nov 22 '13 at 7:27
    
Evidently you are not turning off all of them. Try for example to use autoruns to search "Skype" and uncheck all of them, then reboot. –  harrymc Sep 11 at 7:20
    
I don't think that is evident at all @harrymc. There are only two instances of Skype, and both have been unticked. –  Steve Sep 15 at 11:29
    
I have 7 references to skype that I have unticked in autoruns and they stay that way. Are you doing the search in autoruns inside the "Everything" tab? Have you run any registry-cleaning product? –  harrymc Sep 15 at 12:25

7 Answers 7

I've been in a similar situation. Try this.

Two programs I use are: Windows Process Explorer, and Online Armor Free by Emsisoft. Windows Process Explorer is a standalone program that will give you detailed information on running processes in the background. Online Armor is a security suite (30 days trial; but afterwards lets you choose full version or limited freeware mode) that has low memory usage for me and doesn't slow down startup much, but requires some training if you wish to use all its security features. I suggest getting both.

Windows Process Explorer shows me the parent process and any child processes associated with the autorun offender so I know what to look for in the Autoruns tab of Online Armor Free. The Autoruns tab will list various dll's, drv's, sys's, and exe's associated with startup programs and services. There, you can get more information on the file to locate the registry keys if you want, but registry keys can be respawned sometimes. All you really need to do is Block the parent process or child process, depending which one does exactly what you want.

For example, in Windows Process Explorer the parent process for TeamViewer is TeamViewer_Service.exe and one of its child processes is TeamViewer.exe. If I go to Autoruns tab in Online Armor Free, it will show TeamViewer_Service.exe and I can set it to Block. Then it won't autorun at startup, even if another file or service tries to re-enable it in autorun.

Online Armor deals with unwanted autoruns by blocking the autorun itself; it does not act as a switch on/off for autoruns (unlike some programs out there). Ensuring that if the autorun is re-enabled at reboot, the autorun still won't do anything unless the autorun spawned under a different name; but even this can be dealt with in another way. This has saved me trouble even with programs that re-enable autorun if I manually execute the program (if I ever need to use it). And it has worked even on stubborn startup services that almost nothing else worked against.

share|improve this answer

Use autoruns which is downloadable from, amongst other places, Sysinternals. This will show you all the processes that are started at boot time. It shows services, drivers, registry entries, etc.

Within the tool you can deselect a startup and it will be tagged in the registry so that it will not restart, the programme cannot replace its autostart setting.

share|improve this answer
    
Thanks Chenmunka. Autoruns did the trick. –  Steve Nov 22 '13 at 7:47
    
the problem has returned. When I try to deselect Skype or TeamViewer, Autoruns gives the error: Error changing item state: The system cannot find the file specified. I've created a new question for this error here. –  Steve Nov 28 '13 at 10:08

Although this answer may be lower quality, and you prob went over these already, I didn't see this mentioned. For the sake of completeness:

First, make sure any antivirus, antimalware, or whatever else is not protecting your startup/services. Sometimes these apps make a "cage" to prevent malfeasantware from mucking your registry/startup. If you find this is the case, attempt your disables from within the protector app.

Next, in the settings (or notify icon) for the apps you want to stop from starting at boot: make sure to turn off any of their "start this app with windows". At least a couple of those should have settings for this. Leaving the setting for this "on" at app level can sometimes force msconfig to obey.

Now, along with some of the excellent suggested apps here, ccleaner has the ability to actually remove the startup entries completely. Unchecking to "disable" is a safer bet, but ive found that in the past, removing them completely tends to be quite failsafe (assuming that their app settings say no run at boot). Backup your registry or make a restore point, then delete their startups.

The reasoning behind this is that disable leaves the keys present, whereas deleting the key often requires a software reinstall to put it back in. If its something you arent gonna miss, delete it. If it still comes back this could be a sign that an underlying app is protecting (or hijacking) your winders boot.

Not looking for votes, just wanted to add complete theories to the already good answers.

share|improve this answer

Click on start menu button and then type msconfig Left click on msconfig and then select properties and then click on the security. When you are done doing these step click edit and give you user full permission and then click apply and then Ok button. See if it works or not.

share|improve this answer

For some reason it looks like disabling autorun entries from msconfig doesn't take effect. If I were you I'd try to disable entries in the registry at the key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run

share|improve this answer

Something that might be worth a try--WinPatrol is a free utility that blocks programs trying to make changes to your system. I believe it includes a setting to block specific programs without asking each time.

share|improve this answer

This happens because these programs resets these settings them selves. If you check your services list you will some of the programs there. You could set the individual services to manual as start-up and then start their corresponding program when necessary. When you start the program this should also start the service.

EDIT: Chenmunka pointed out to me that not all the programs you are listing are services and I am sorry for giving false information.

share|improve this answer
    
Not all these programmes are services. –  Chenmunka Nov 21 '13 at 12:37
    
Ah sry about that. You are correct. At least the TeamViewer is a service, and altough I am not on a computer with QuickTime installed this should be governed by an Itunes service. –  Oddxen Nov 21 '13 at 13:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.