Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Windows 7 (Home Premium) machine that doubles as a media centre and subversion server. There's a couple of problems with this setup, when connecting to the server from an XP (SP3) machine:

Firstly, the machine won't respond to it's machine name until after it's IP address has been pinged. Here's an example:

Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Rob>ping damascus
Ping request could not find host damascus. Please check the name and try again.

C:\Documents and Settings\Rob>ping 192.168.1.17

Pinging 192.168.1.17 with 32 bytes of data:

Reply from 192.168.1.17: bytes=32 time=2ms TTL=128
...

Ping statistics for 192.168.1.17:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 1ms, Maximum = 2ms, Average = 1ms

C:\Documents and Settings\Rob>ping damascus

Pinging damascus [192.168.1.17] with 32 bytes of data:

Reply from 192.168.1.17: bytes=32 time<1ms TTL=128
....

Ping statistics for 192.168.1.17:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 1ms, Average = 0ms

C:\Documents and Settings\Rob>

Likewise, subversion commands with either the machine name or IP address will fail until the machine's IP address is pinged. Occasionally, the machine won't respond to pings on it's IP address, it'll just come back with "Request timed out". The svn server is VisualSVN, if that helps...

Any ideas?

share|improve this question

3 Answers 3

up vote 2 down vote accepted

I would check the DNS settings.

Where is the DNS Server? ipconfig /all | Does this client have a DNS server set in the adapter?

Does the DNS Server have a host record for this client?

share|improve this answer
1  
This occurred to me when trying to explain the problem to my non-technical girlfriend last night. I've set up a static route on the router that acts as the DNS server and it seems to have resolved the issue. –  rjohnston Nov 9 '09 at 21:11

First thing I would check is any firewall you have just in case.

Next, it sounds like there are DNS issues on your network. It could be that it takes a ping request for DNS queries to resolve / find that machine - after the ping, the hostname gets cached.

If the IPs never change, personally, I would just stick the hostname in the hosts file and point to the correct IP. This should fix the problem you are having.

To edit the hosts file - open c:\windows\system32\drivers\etc\hosts then put the ip followed by the hostname. (Follow the example)

share|improve this answer

I am running Windows 7 Enterprise and have been experiencing similar issues. Sometimes I could RDP and sometimes I couldn't. I then realized that I couldn't even ping, with all firewalls disabled, even from the PC to itself. I could ping via the ping back address but not by the IPv4 address. I flushed DNS and that worked for about a minute. It was will I was looking at the LAN Connection properties that I saw the Virtual Machine Network Service. I had installed Virtual PC but haven't had time to use it. I cleared that check box to disable that protocol and it worked right away. Hope this helps.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.