Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The software that came with my network card indicates that my max speed is 54Mpbs when connected to my home wireless network, if I modify the Tx Power adjustments in the software I am able to get lower numbers but not able exceed 54Mbps as the speed it informs me of.

I originally suspected this was due to someone connecting a wireless G device to a single band N router in the apartment, so I bought a new dual band AC router to replace the N router that had existed. The problem did not change, leaving me looking foolish.

It is my understanding that this rules out a G or other outdated device limiting the network as it could limit the 2.4 GHz band to 54Mbps but leave the 5 GHz AC specific band unmodified. Then again this may not be even remotely correct, so please correct me if I have gross misconceptions on how this works.

I do not have control over the router and after my apparent misdiagnosis of the issue previously, I will need to be more specific than "hey you misconfigured the router because if you hadn't I should have a faster connection" if I expect the roommate who maintains control over the router to look into it.

What could be wrong with the configuration or otherwise causing this 54Mbps speed cap?

Adapter: http://www.asus.com/Networking/PCEAC66/
Router: http://www.asus.com/us/Networking/RTAC66R

Edits: I am unable to move them to same room as the router is in my roommate's bedroom. The walls are made of 2x4s, drywall, and insulation, you know standard wall stuff (not concrete or stone or anything fancy like that). Both my bedroom and the bedroom with the router are off of the kitchen so they are close to each other maybe 20 feet between the two points (the refrigerator is NOT located between the two points in any way) And the max is suspiciously 54 mbps but can be lowered by adjusting the Tx to be extremely low power. At about 40 mW on a scale of 1 to 200 for Tx settings it caps at 54 and will not exceed that.

Apparently the encryption on the router is set to WPA2-PSK AES

The channel is set to 1 (there is only 1 other router in range with channel 1 it uses WPA/WPA2-PSK TKIP+AES)

The value reported by the software as Signal ranges anywhere from -43 dBm to -54 dBm depending on where I place the antenna, the Tx settings, and whether I am touching it. Usually it is around -45 dBm with the settings pictured below, sitting in the most convenient spot on my desk.

Picture of Power slider in software (Default settings pictured) http://imgur.com/LhY1Meq

share|improve this question
    
You seem to indicate that you have a 802.11ac-capable adapter, but also that "the software that came with my network card indicates that my max speed is 54Mbps". Which one of these is correct? –  MariusMatutiae Nov 21 '13 at 16:40
    
Take the wireless adapter and router into the same room. What are your speeds? If not what are your walls made out of? –  Ramhound Nov 21 '13 at 16:48
    
MariusMatutiae: I am saying BOTH, that I have an AC adapter (and router) and that the software is indicating a max speed of 54mbps. That is the entire reason I am asking the question, the box indicates the max speed of the adapter, as it should be for an AC adapter, is much faster but the software is indicating its max speed is 54mbps right now. –  Will Nov 21 '13 at 17:23
    
I have added information regarding the wall construction, layout and distance between points to the above post. Moving the computer to the router is impractical due to it being located in my roommates bedroom. I do not believe interference alone would adequately explain this issue, if you believe it does could you please provide an explanation of how AC would get knocked down to G speeds on this kind of range, in a fairly average house. –  Will Nov 21 '13 at 17:29
    
Many routers have the ability to limit bandwidth for users. Say primary users and guests exist.. Primary user gets full bandwidth and Guest user gets less. You will need to discuss with the roommate. –  Dave M Nov 21 '13 at 17:45

1 Answer 1

The first thing to check is to make sure you're using WPA2 (a.k.a. "WPA2-PSK", "WPA2-Personal", "WPA2-Enterprise", "802.11i with AES-CCMP") encryption if you're using encryption at all.

The 802.11n and 802.11ac standards both require AES encryption because the older wireless encryption types—(WPA (TKIP), and WEP) can't keep up with N and AC data rates. If you don't configure your AP and client for AES, you'll be forced to 802.11a/b/g rates, which max out at 54mbps.

If that's not your problem, then it could be that your client is far enough away from the AP, or there's enough interference on the channel, that the signal-to-noise ratio (SNR) is so low that N and AC rates aren't maintainable, so it's using A/G rates by choice. If your software can show you your SNR in dB, or your separate signal strength (RSSI) and noise in dBm, then update your Question with that information. At the very least, RSSI in dBm is a hugely important measure in any discussion of Wi-Fi rates and range.

Also, your roommate's router is a simultaneous dual-band router, and your client card is capable of using either band. Did you say that you're seeing the same 54mbps cap in both bands? Relatedly, I'm concerned about this notion of a power slider in mW that only goes up to 200. In most regulatory environments, devices are allowed to use up to 1 Watt (== 1000 mW == 30dBm). I'm pretty sure that the RT-AC66R has high-power amplifiers that allow it to reach the regulatory max, so it's weird to hear you describe UI that seems to suggest it's limited to 200mW. Or maybe I didn't understand your description of the slider.

In a separate comment, you said it would be inconvenient to move your computer close to the router, but couldn't you convince your roommate to let you temporarily move the router into your room to see what connection rate you get? It doesn't have to stay hooked up "to the Internet" for this, just plug it into power in your room and see what 802.11 signaling rate your software says you're getting.

Another tip since you're using an internal card in a desktop PC: The inside of a PC case can be an very RF-noisy environment. Hopefully your card is well-shielded to prevent receiving interference from other internal components. Make sure your card's port fence is making good contact with the grounded shielding of your PC case. Make sure your antenna leads are screwed on tight. Make sure your antennas are as far away from your PC case and monitor as possible. The most common source of Wi-Fi interference in a PC (well, besides Bluetooth obviously) is the graphics card, video cable, and monitor. Hopefully your situation won't come down to RF interference engineering within your own PC.

By the way, You do have a gross misunderstanding of 802.11; it has never been the case that connecting an older-generation device to a wireless network would drop the whole network down to that older-generation speeds. That is an unfortunately pervasive myth that has always been false. If your AP and client are AC, your AP and client will talk to each other at AC rates when either of them has something to say to each other, and the G client and the AP will talk to each other at G rates when either of them has something to say to each other. This is one of the things the Wi-Fi Alliance's Wi-Fi logo certification program tests for. Any device with a Wi-Fi certified logo on it has proven that it does not switch to older-generation rates just because an older-generation device has joined the network.

share|improve this answer
    
Thank you, I am not certain encryption is set to WPA2 it may just be WPA, which would conveniently explain the situation and hopefully be an easy fix and I was completely ignorant of this bottle neck on the older WPA encryption so would not of considered it odd. As for trying out the router by moving it without 'internet' I will try that when I have a chance if the encryption does not turn out to be the issue. I have tried unhooking and and reconnecting my antenna cables to the card and tried the antenna in different locations to the extent the 4 foot long cord allows, it did not help. –  Will Nov 21 '13 at 18:32
    
Also thank you for clarifying 802.11 for me, my incorrect understanding of it made it seem a bit ridiculous, so I am glad to hear it is not so poorly designed. I do not know where I originally acquired that misconception but thank you for correcting me. –  Will Nov 21 '13 at 18:38
    
I will add a screen shot of the slider with the settings that are available to me when I get home, I was fairly certain the slider did not go above 200 mW but as is apparent already I am wrong quite a bit. Also I believe there is a signal to noise ratio specified in one of the software tabs so I will include that when I do update. –  Will Nov 21 '13 at 18:40
    
Apparently although I never paid attention to encryption it is indeed using WPA2-PSK AES. Just got home from work and roommate is already in bed so probably won't get a chance to try things involving moving stuff around till the weekend. –  Will Nov 22 '13 at 4:28
    
@Will Be sure to pay attention to how both the AP and the client are configured. If one is configured to accept both, but the other is configured for just WPA[1] (TKIP), then you might be connecting via WPA/TKIP instead of WPA2 with AES. -45 to -53dBm are excellent RSSI ranges, so distance isn't likely to be the problem. I see your power sliders are on your client. Crank them all the way up. Also, be sure to check your connection speed while you've got a steady stream of traffic moving, not just while idle. Some clients report lower rates while idle. –  Spiff Nov 22 '13 at 20:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.