Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have tried to install FreeBSD on Asus G75VW. Setup will partition the disk, install everything.

At reboot I see this: "Reboot and select proper boot device" "or Insert Boot Media in selected boot device abd press a key"

So basically it has no idea there is an os. gpart show this as partitions: freebsd-boot freebsd-ufs freebsd-swap

Just to be clear, this is FreeBSD-only setup. As a test I installed Windows-only and Ubuntu-only setups and they both run well after reboot.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

According to this site, the EFI boot loader for FreeBSD has yet to be integrated into the FreeBSD binary releases. I haven't checked the status myself, though, so I can't be sure that the information is outdated.

It's not 100% clear from your description if you're doing a FreeBSD-only setup or if you're triple-booting with Windows and Ubuntu. If the latter, that could cause complications, since on a GPT disk, Windows will insist on booting in EFI mode. Switching between BIOS-mode and EFI-mode booting is usually a bit awkward; however, my rEFInd boot manager can simplify the task on some (but not all) computers. Basically, you'd install rEFInd and edit refind.conf: Uncomment the scanfor line and ensure that hdbios is among its options. This will enable rEFInd to chain from a standard EFI-mode boot into the BIOS-mode FreeBSD boot loader.

Although using rEFInd in this way might work if you've got a FreeBSD-only system, a simpler solution may work: Using a GPT-unaware partitioning tool, set the "boot flag" (aka the "active flag") on the MBR's type-0xEE protective partition. Some EFIs refuse to start an OS in BIOS/CSM/legacy mode unless an MBR partition is marked as active, and this workaround will satisfy such EFIs. See my Web page on this topic for more information and some other suggestions, should this solution fail.

share|improve this answer
    
This is a FreeBSD-only setup , I will correct the question –  user265764 Nov 21 '13 at 23:35
    
I will try what you suggest. A subquestion in this case - how can I boot the installed freebsd so I can install the boot manager ? From live/install CD how do I do that ? –  user265764 Nov 21 '13 at 23:43
    
If you've done a complete install, the FreeBSD boot loader should already be present on the hard disk. If so, setting the boot/active flag on the MBR's 0xEE protective partition will probably get the hard disk booting. You can use an emergency boot disk to adjust the partition table. Any but the latest versions of Linux's fdisk should do the trick. I'm not sure about FreeBSD tools, offhand. –  Rod Smith Nov 21 '13 at 23:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.