Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

At home I have a wi-fi connection. I usually connect to wi-fi with my Windows7 laptop. The connection is good because I'm not so far from router; it is also an open connection, that is it is nor WEP or WPA. I've decided, then, to add a WPA2 key into the router for my wireless connection. After that, I've noticed that my connection on laptop goes down intermittently. I have other devices that I used with wi-fi connection and noone has connection problems...I've this behaviour only on my Windows7 pc laptop... Anybody can help me?

EDIT: My router is DLink DSL-2640R (but I don't think that it is a router problem because other devices works well with this configuration). I've set up also the automatic channel scan for wireless and only 802.11g (it does not made for .11n). On my pc I have the Atheros AR9285 wireless adapter

share|improve this question
    
Have you tried switching the broadcast to a different channel while using WPA2? –  Moses Nov 21 '13 at 21:25
    
I'm going to do it and I will notice you...please give an answer and I will give feedback there –  FrancescoDS Nov 22 '13 at 13:38
    
I've tried to give an automatic search of channel. Router automatically choose 11, but it does not work: it seems that connection goes down when I try to load some new webpage... –  FrancescoDS Nov 22 '13 at 13:45
    
You didn't give much info about what equipment/settings you use. If you're on 802.11n with the laptop you could setting it to 802.11g. What is the "link"-speed you're getting? –  Rik Nov 24 '13 at 20:54
    
What do you mean with equipment and settings?I can say that my router supports only 802.11g and b. –  FrancescoDS Nov 25 '13 at 8:18
show 3 more comments

1 Answer

up vote 0 down vote accepted

I recently had to install a BT Homehub 4 for my parents and one of the laptops in their house refused to connect. It was simply down to the wireless encryption format being too "new" for the hardware. Windows recognised it with no issues but refused the connection.

Once the connection was established with WEP everything was fine again albeit a little slower.

share|improve this answer
1  
with WEP everything works well. I will see about issues of my wireless adapter with WPA2 –  FrancescoDS Nov 25 '13 at 19:42
    
It's odd how new can be baffled by old –  Adsy2010 Nov 26 '13 at 0:20
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.