Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a usb key, it is working fine on my other machine. However, on this computer, when I plug it in, it recognizes it but will not load up as accessible under 'My Computer' and no autoplay stuff comes up. What gives?

share|improve this question
up vote 5 down vote accepted

Right click My Computer and click manage, open Disk Management and ensure the USB device is assigned a drive letter

share|improve this answer
    
Smooth! Another network drive was using the same letter. Thanks :) – Chris Nov 9 '09 at 13:39

Is it empty?

Control Panel > Folder Options > View > uncheck "Hide empty drives in the computer folder" > click OK.

Ah, seems answer has been posted since I started my post.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .