Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Toshiba A100, which I upgraded to 4 GB of RAM. The hardware startup indeed shows 4 GB of RAM, and I recently installed Windows 7, just to see how it behaves on it. So far so good, it displays 4 GB of RAM. Not that I tried to use it all, but it displays it. Previously under XP, I also would see 4 GB of RAM.

But under Ubuntu 9.10 (32 or 64 bits), it only displays 2.9 GB of RAM. And my kernel is the "pae" compiled one, which is supposed to do the trick to work around the 32-bit CPU limitation.

How can I get Ubuntu to fully use my 4 GB of RAM?

share|improve this question
    
Which exact kernel are you loading? Have you tried one of the server kernels? Which application is reporting 2.9 GB of RAM? What does 'free' report? –  ChrisInEdmonton Nov 9 '09 at 16:00
    
I used the default memory utility that comes in Ubuntu 9.10. I did not thing about using free or other utilities. –  jfmessier Nov 12 '09 at 13:26
    
Um... what exactly do you mean by "the default memory utility that comes in Ubuntu 9.10"? Is it a program you ran from the command line? Or something you ran from a menu? or? –  pbr Dec 3 '09 at 3:44
    
I use a menu option from the Ubuntu 9.10 that shows me information about memory. Also, when I try the free command-line utility, and it shows me 2.9G. –  jfmessier Dec 3 '09 at 13:20

2 Answers 2

up vote 0 down vote accepted

For PAE to work, you will need both system and application that supports it. System you have (kernel), but not all applications will see it since they are usually not compiled that way.

Only applications where developer took extra steps will be able to use that memory. Usually those applications are among ones that are memory-hungry. MySQL as standard example springs to mind.

Although your system and most of your applications only see 3GB, you can be sure that some applications (e.g. MySQL) will know how to use it.

share|improve this answer
    
I'm not sure this is the case. When I boot up Ubuntu with a PAE-enabled 32-bit kernel, I can see all 4 GB of memory in 'free'. Now, don't get me wrong, applications will only see 3 GB of memory for each process, so Josip is not totally incorrect on this, but 'free' should report the full amount. –  ChrisInEdmonton Nov 9 '09 at 15:59

On an Intel system, desktop chipsets 945 and older cannot map any RAM over the 4GB line. This is a hardware limit and cannot be workaround in software. If that is no problem, check your BIOS for memory remapping options.

share|improve this answer
    
Thanks. This is something that I will look into. –  jfmessier May 31 '10 at 11:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.