Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've gone through about 2-3 days of constant searching for this, and have tried many different approaches, but I fear I simply don't understand enough about VPN's to be able to do this without asking for help. Searching suggestions on superuser also yielded me nothing of use.

So my problem is this: My college campus blocks almost all ports, I can still access the internet, use programs such as Teamviewer, however other programs such as Steam, or Origin are blocked. I'm looking for a way to connect to a VPN server that is setup on my home computer (running Windows 7) from my college campus, so that all the campus firewall knows is that I'm connecting to my home's IP address, and all of the data for my internet usage is routed though the VPN. I understand windows has a built in PPTP service, but all of my attempts to set this up have failed. Not sure what other information is needed. Both computers are running windows 7 Home Premium, and my home's cable router (technically I believe it's a wireless gateway) is an Arris Touchstone Telephony Wireless Gateway Modem TG862G.

EDIT: Figured I'd share the error message I'm met with when attempting to connect to VPN from laptop. http://gyazo.com/e4d943eaf0b42f4cd2d52fe614a17d71

EDIT2: Tried the "Diagnose" button shown in the picture above, met me with this: http://gyazo.com/a3031b5a06d84ffe2d9e00a5aebd12e0 Seems like it's telling me that the ports are blocked on the host computer, however I can verify that I have in fact port-forwarded 1723 to my host computers local address. Not sure why it isn't responding. Is a wireless gateway simply incapable of routing a VPN connection to the host computer?

EDIT3: I'd like to make clearer that I am not looking for a simple web-broswer proxy server to run off my home PC. I want all programs on my laptop to be routed through a VPN to my home PC, not just a web browser.

share|improve this question
    
Pretty sure you can do this with Log Me In Hamachi. I prefer Teamviewer, but for your request I think this will work. –  Ryan E Nov 21 '13 at 21:17
    
My experience with Hamachi is limited, and I have no idea how I would route my internet traffic through it to my home PC. Could you point me in the direction of a guide/tutorial? –  Patrick Cunningham Nov 21 '13 at 21:30
    
lifehacker.com/5763170/… –  Ryan E Nov 21 '13 at 21:44
    
This appears to only route internet traffic from a web-browser through the proxy server. I want to be able to route the entire connection to the proxy/VPN server, not just for web browsing, but for any program that uses the internet. –  Patrick Cunningham Nov 21 '13 at 21:49
    
Changed my answer to accommodate your request. –  Ryan E Nov 21 '13 at 22:16
show 1 more comment

2 Answers

up vote 0 down vote accepted

Using Log me In Hamachi and following this "Route all traffic through Hamachi" should accomplish what you are after.

Log Me In Hamachi

share|improve this answer
    
Seeing as Rik informed me in a indirect way that my router simply can't handle what I had hoped to do, your solution is a very sound work-around. Thanks for the information. :) –  Patrick Cunningham Nov 22 '13 at 16:54
    
@PatrickCunningham i added some info to my answer. According to the manual you should have a "PPTP Passthrough" in the Firewall-page of the modem (on the Gui-Web interface of the modem). If you don't, Hamachi is another way to go. –  Rik Nov 22 '13 at 17:34
add comment

There is usually a setting called "PPTP Passthrough" or something in your router. You need to enable it along with the forward of port 1723.

A error code 807 typically is either the client or the server is behind a NAT device and does not pass through GRE protocol 47. If GRE protocol 47 isn't pass through the NAT device you'll get 807. you'll also get 807 if port 1723 isn't forwarded from the NAT device to the VPN server if the server is behind a NAT device. VPN servers usually have packet filters which restrict inbound connection to only PPTP or L2TP.

Edit:

According to the Arris TG862G manual you should have a Firewall-page in the Web-Gui of the modem where you can enable "PPTP Pass Through".

enter image description here

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.