Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've tried KDE 4.0.x/4.1.x/4.3.x ( RC2 ) but I can't seem to accomplish a simple task:

Launching Konsole using a keyboard shortcut

The way I used to do this with KDE 3.5.x would be to :

  • right-click on the start menu;
  • navigate to the Konsole entry;
  • select a shortcut;
  • click Save.

And it worked. But not on KDE 4.x.

Any suggestions on how to make it work on KDE 4.3.x?

share|improve this question
add comment

5 Answers 5

up vote 9 down vote accepted

This one's easy.

Go to System Settings > Input Actions. In the selection area, do right click > New Global Shortcut > Command/URL. Make sure you give it a name, a shortcut, a command, and tick the Enabled box. Click Apply and you're done.

Coincidentally, though, the the "Examples" group should already contain an action named "Run Console," activated by Ctrl+Alt+T. Note that you'll need to enable shortcuts for the parent "Examples" group before you can enable "Run Console."

share|improve this answer
add comment

For some reason, the kmenuedit shortcuts were shipped 'disabled' in the recent KDE releases.

Go to System-Settings, then Shortcuts-And-Gestures.

Select the 'Custom Shortcuts' on the left column, then make sure the 'KMenuEdit' entry is CHECKED.

Apply and close that application.

Now, when you create/edit the shortcut keys in the KMenu, they will be active and work immediately (as we both expect!!)

Took me a bit to figure this out, I thought the hotkeys were broken broken, and I REALLY use WIN-S to open a shell, WIN-C for calculator, and many more. Mouse? Don't need no mouse!

share|improve this answer
add comment

In general I do this with kmenuedit, which I believe should be the prefered way of assigning applications to a keyboard shortcut.

  1. Launch kmenuedit
  2. Choose the application you wish to start from the tree on the left
  3. Click on Advanced.
  4. Select the Current shortcut key and click on Save.

Note that until KDE 4.2 there was a bug that causes KDE to ignore this shortcut. So in case you do not have KDE 4.2 or 4.3 yet, consider upgrading.

share|improve this answer
    
Thanks for the answer. This did not work for me in KDE 4.3.0 and this is why I posted the question. –  Robert Munteanu Sep 21 '09 at 22:11
    
There is an open bug report: bugs.kde.org/show_bug.cgi?id=170455 –  Yaba Sep 23 '09 at 10:42
add comment

Or to do this in the current version of KDE 4.8.4, its almost the same as the answer given by Nikhil Chelliah, its just that some things have been renamed.

1.) Goto "System Settings" from the main panel launcher (For a default install of KDE it will be in the favorites tab, but you can also do a search for this using the main panels launcher's search bar by typing in the words "system settings" without quotes. Alternatively you can also press ALT+F2 and type in "system settings" without quotes to get to the system settings panel.

2.) In the system settings panel you will see 5 titled rows or sections that group various tasks together. Look in the 1st section at the top tittled "Common Appearance and Behavior". In this section you should see an icon labeled "Shortcuts and Gestures" (this icon should be the 6th icon from the left towards the right). Click on this icon.

3.) From here you can finish following the steps given by, Nikhil Chelliah, except that your activate check box might not be labeled, but it should be fairly obvious at this point what the gist of things are. :)

Hope this helps.

share|improve this answer
add comment

this is not the answer to your question, but have you tried yakuake? it also goes fullscreen with ctrl+f11

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.