Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I click start, and then 'All Programs' (or select a sub menu of all programs) I get a grey menu which does not respond for about 5 seconds - after this it is ok.

Any idea what is causing the menu to behave sluggishly? What can be done to fix this?

Thanks

Info Requested System Specs : Core2 T5500 @1.66GHz, 2GB Ram

Windows version: XP Professional SP2

Happens Every time I click the menu (not just first time), has gradually been getting worse.

Nothing too unusual at startup: ComodoFirewall, AVG AV, Truecrypt (only for small volume).

AV Software: AVG.

share|improve this question
    
It could be any number of things causing sluggish response. We're going to need more info to go on. What are the specs of the system in question? What flavor of Windows XP are you using (Home, Pro, MCE)? How often does this happen (Every time you click on Start > Programs? Only the first time you click on it after you boot the system?) When did you notice this started happening? What programs do you have running at startup? What (if any) anti-virus software are you running? Give us a bit more to run with and we can see what we can do. –  TechParadox Nov 9 '09 at 14:58
    
Info extended - thanks. –  UpTheCreek Nov 9 '09 at 15:11
add comment

8 Answers 8

up vote 2 down vote accepted

What's happening is that XP is reading through all the Start Menu folders and entries. Some amount of rearranging (grouping similar folders together in a parent folder - I have ones for "Utilities", "Multimedia", "Applications", etc) can speed things up. However, if you're really loaded with applications and short on memory, nothing short of uninstalling some of that stuff will help.

share|improve this answer
    
I've uninstalled quite a lot, not too much on there now. 2GB ram, and seems enough spare. –  UpTheCreek Nov 9 '09 at 15:12
    
RAM isn't the point. When you click All Programs, Windows has to read all that information from disk. It's not impossible that defragging will speed things up. –  CarlF Nov 9 '09 at 15:18
    
I was just responding to the 'short on memory' comment in the answer. –  UpTheCreek Nov 9 '09 at 15:22
    
I have a 3GB RAM machine and he described the same symptoms I get the first time I try to fully expand the Start Menu. At least on my machine, it seems to have cached the Start Menu entries as all subsequent attempts go MUCH faster, whereas the first time also has my disk light flashing like crazy. –  David Nov 9 '09 at 15:41
add comment

One culprit that I've seen is shortcuts that point to network drives; these can cause Explorer to pause or lock up for a few seconds while it tries to resolve those network drives so that it can load icons for the shortcuts.

On a related note, if you've copied shortcuts from another computer (such as via a roaming profile), and the shortcuts' destinations don't exist on your computer, then Windows may automatically try to access the original computer over the network to update the shortcuts to point to that original computer's hard drive. (For example, a shortcut pointing to c:\MyComputerSpecificApp.exe will be updated to point to \MySpecificComputer\c$\MyComputerSpecificApp.exe. This is going from memory; it's been a while since I've dealt with this behavior.) I believe that this is part of the behavior that Raymond Chen is describing here.

It doesn't sound like you're doing any network shortcuts or profile roaming, so I doubt this is your problem, but these things are simple enough to check.

share|improve this answer
add comment

Based on what you've given us I'd suggest taking this tack on troubleshooting the issue: Bring up the Task Manager, switch to the Processes tab, and then sort it by CPU. Keep an eye out on what processes are using the most CPU time and then click on your Start button and head up to All Programs. I run AVG on one of my older XP boxes and I've noticed AVG's resident scanner has a tendency to chew up a HUGE amount of CPU cycles whenever I open a folder on that box, resulting in a lag of several seconds before the file names start appearing and icons populate properly. You may be running into the same thing on your PC.

share|improve this answer
add comment

One thing you can do is if you have two columns, remove enough items to get it back down to one.

share|improve this answer
add comment

This is AVG's resident shield - If you put task manager on your screen and order it by "CPU Load" you'll noticed that when you get the problem - AVG will go up in CPU use. Disable AVG's resident scanner and it will go away.

I've decided to live with the problem - as I'd rather have some antivirus protection and AVG is otherwise quite reasonable for the price.

share|improve this answer
add comment

If you would like good virus protection for free Microsft Security Essentials is free and has done very well for my PC's so far. I was an avid AVG user before MSE and it could lag the PC's a bit MSE is much cleaner.

share|improve this answer
add comment

Try this:

Right click My Computer, select Properties, then click the Advanced tab.

Click the settings button under the performance window. Click the radio button for Custom and uncheck Fade or slice menu's into view.

Close the open windows and give a try.

share|improve this answer
add comment

Turning off "Show shadows under menus" solved the slow start menu problem for me:

From https://webapp.usm.maine.edu/WebFAQ/?1803

Turns out there is an easy fix. Right click on the Windows Desktop and choose Properties. Then choose the "Effects..." button on the "Appearance" tab. Make sure that the "Show shadows under menus" item is unchecked.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.