Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I plugged in a friends iMac via firewire taget mode to clone his drive to an image and something strange went down. Now I can't log into my user account properly and Macintosh HD has a red no go sign on it when I command-click the finder title. Get Info shows 'Fetching" instead of 'Me' and finder won't show any files when browsing Macintosh HD. Closer inspection shows Macintosh HD to be owner by uid 502 but all other drives are uid 501.

I figure I need to get that back to 501 somehow.

Running the installer from USB and running terminal there iv'e tried.

cd /Volmes/Macintosh HD

chown 501:501 Me

and

chown 501:20 Me

but it remains 502.

How can I fix it?

P.S OSX is installed on 'Macintosh SSD' and my home folder is on a separate drive'Macintosh HD'

share|improve this question
    
Are you positive that uid 501 is the correct user? –  Ramhound Nov 22 '13 at 18:14
    
Well I'm not %100 clear on the uid scenario but that is the uid of my user account and all other files and volumes have that ownership. It's only Macintosh HD that now has 502. –  TijuanaKez Nov 22 '13 at 18:20
    
Another odd thing is now if I boot into OSX, 'ls /Volumes' shows a 'Macintosh HD' and a 'Macintosh HD 1' aswell as 'Macintosh SSD' etc. I don't know where the extra mount point is coming from as 'distil -list' definitely only show one partition with that name. –  TijuanaKez Nov 22 '13 at 18:24
    
ok 'chown 501:20 /Volumes/Macintosh\ HD/' managed to change that volumes owner but I still get 2 mount points for 'Macintosh HD' when I load OSX and the drive appears empty (in finder but not in terminal). Any ideas? –  TijuanaKez Nov 23 '13 at 2:46

1 Answer 1

up vote 0 down vote accepted

chown 501:20 /Volumes/Macintosh\ HD/

from recovery partition or

sudo chown 501:20 /Volumes/Macintosh\ HD/

from terminal inside OSX

Note it was only the volumes itself with wrong hid. If all the files and folders on the volume are wrong then need to do it recursively ('chown -R')

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.