Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Linux Mint 15 desktop and Windows 7 laptop that I am attempting to share files and a printer with. I have a bit of an odd problem that I can't figure out how to resolve.

I've configured the SAMBA GUI on the Mint machine and the file sharing options in the W7 Control Panel and double-checked them as best as I can. The end result is that my Mint machine can access my W7 shared folders, but the W7 computer can't even see the Mint machine, either in the network browser or when I try to add the printer that's connected to the desktop.

I can ping the LM machine's IP with no problems.

For troubleshooting purposes, I loaded up some virtual machines with bridged network adapters to try and connect to the various shares: a W7 VM, Linux Mint 15, and Windows XP.

The end result is that both Linux Mint machines, real and virtual, can see all the computers on the network, including the virtual machines. My W7 machines can only see itself and the other W7. XP can see itself and both W7 machines.

I had file & printer sharing before when the desktop was running Xubuntu 12.04 before, but now that I've changed it over to Mint I can't figure out why I can't see it.

EDIT: I think I figured it out. It looks like the host name for the Mint machine was too long (it was > 15 characters). Once renamed it to something shorter, it shows up on all my machines, even the virtual ones.

share|improve this question
    
How are you trying to link to LM from W7? With full IP address, or with name? –  MariusMatutiae Nov 25 '13 at 17:05
1  
have you tried manually typing the share path to the mint machine? \\server\sharename ? On Mint, does your firewall allow all hosts access to TCP\137,138,445 and UDP\135,139 ? note that if the firewall allows only your local network range, it will block NETBIOS name resolution broadcasts. please post a copy of mints smb.conf file. –  Frank Thomas Nov 25 '13 at 17:16
    
Marius: I am trying to see the computer in the Network part of the file Explorer. –  user276853 Nov 25 '13 at 21:34
    
Frank: I just tried in the Run dialog and it didn't work. I'm not sure about anything regarding the firewall, as I left it at the default settings. I don't remember having to set up the firewall when I did this with a Xubuntu install, though. –  user276853 Nov 25 '13 at 21:36
    
Where does the Mint machine see your Windows? In the 'Network' or in the 'Windows network'? Is the workgroup for samba the same as the workgroup on windows? If I remember correctly, Windows7 changed the default name so that might be why the older windows work. –  terdon Nov 25 '13 at 23:13
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.