Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In Intrepid, when I logged into my desktop over SSH and launched Rhythmbox (ssh hostname -XYC), it would play the sound out the desktop's speakers, which is what I want. Now in Jaunty, it plays the sound out my laptop's speakers, which I don't want. How do I configure the audio to come out the server's speakers when I connect to it over SSH? Has this changed again in Karmic?

Do you know of a better solution for this problem? (Sending audio from laptop to server wastes bandwidth compared to just sending the GUI data from server to laptop.)

share|improve this question
    
I had "Enable network access to local sound devices" enabled on the laptop, and when I disable this, the sound on my laptop stops. It doesn't play through on the desktop, though. –  endolith Nov 10 '09 at 3:07
    
If I run music players in an NX windows, the audio goes to the right place. Kind of a kludge, though. –  endolith Nov 10 '09 at 3:32
add comment

2 Answers

up vote 1 down vote accepted

I disabled "Enable network access to local sound devices" and "Make discoverable network sound devices available locally", then rebooted. Now the sound comes out the local speaker instead. I have no idea why it connects backwards like that when logged in over SSH.

share|improve this answer
add comment
ssh -X user@server "audio-player-application"

This plays music on the server, but displays GUI on the client ;) "-X" stands for "X session forwarding". Also try "-C" to compress the data, and "-fnN": this makes ssh go background after it asks for password.

share|improve this answer
    
That's what I'm using. It plays the music on the laptop. –  endolith Nov 9 '09 at 19:19
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.