Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I mounted a few drives from Linux boxes in my network, but those mounts aren't case-sensitive.

The mount command I used ( from the man mount.cifs, case-sensitive should be the default ):

mount //10.0.1.10/remote_folder /local_folder -t cifs -o username=xxxx,password=xxxx

but those mounts aren't sensitive. for example doing:

ls -l /local_folder/testfile.txt
ls -l /local_folder/TESTFILE.TXT

give's the same result... instead of 'file not found'

Couple of important points:

  1. All drives are running on Linux machines.
  2. My local machine is running Fedora 18 and it is case-sensitive for ANY folder/file expect the mounted drives.
  3. All drive/mounts are case-sensitive when when doing SSH. So if I SSH from my local machine to a remote machine, doing ls -l /local_folder/TESTFILE.TXT will say file not found as it should.

So I believe the issue is in my local machine and not in the way I did the mount. but I'm not sure where to look next (I'm new to Linux)

share|improve this question
1  
I'm pretty sure this is due to the underlying CIFS volume not being case-sensitive. Put another way, the server with the filesystem (10.0.1.10) probably doesn't support case sensitivity. The filesystem isn't case sensitive (though it is case-preserving). –  ernie Nov 25 '13 at 18:46
    
@ernie That was my first though too but then wouldn't it also be case insensitive when connected by ssh? –  terdon Nov 25 '13 at 23:04
    
Are there any settings in smb.conf on the 10.0.1.10 server that restrict case sensitivity? –  rickhg12hs Nov 26 '13 at 21:42
1  
Though it does seem weird to be using SMB/CIFS shares on an all Linux network . . . –  ernie Nov 26 '13 at 22:00
    
Mounting as NFS fixed the case-sensitive issue. I couldn't figure out why cifs would not work. –  Asi Mar 26 '14 at 3:44

1 Answer 1

It's likely that you are seeing a bug. The Samba server seems to mistakenly assume that clients with certain capabilities must be Windows Vista (which wants case insensitive). Newer versions of the Linux kernel CIFS now have those additional capabilities, thereby confusing the server into treating the client as if it were Windows Vista. More detailed report with code patches: http://www.spinics.net/lists/linux-cifs/msg09530.html

Meanwhile, on the client side, you can easily avoid the issue by including, among your mount options in /etc/fstab, the option "sec=ntlmv2".

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.