Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.
  • Starting Tomcat servlet engine tomcat7 [fail]

CATALINA.LOG

> Nov 26, 2013 9:02:09 AM org.apache.catalina.core.AprLifecycleListener
> init INFO: The APR based Apache Tomcat Native library which allows
> optimal performance in production environments was not found on the
> java.library.path:
> /usr/java/packages/lib/amd64:/usr/lib64:/lib64:/lib:/usr/li Nov 26,
> 2013 9:02:09 AM org.apache.tomcat.util.digester.SetPropertiesRule
> begin WARNING: [SetPropertiesRule]{Server/Service/Engine/Host} Setting
> property 'debug' to '0' did not find a matching property. Nov 26, 2013
> 9:02:09 AM org.apache.tomcat.util.digester.SetPropertiesRule begin
> WARNING: [SetPropertiesRule]{Server/Service/Engine/Host} Setting
> property 'debug' to '0' did not find a matching property. Nov 26, 2013
> 9:02:09 AM org.apache.tomcat.util.digester.SetPropertiesRule begin
> WARNING: [SetPropertiesRule]{Server/Service/Engine/Host} Setting
> property 'debug' to '0' did not find a matching property. Nov 26, 2013
> 9:02:09 AM org.apache.tomcat.util.digester.SetPropertiesRule begin
> WARNING: [SetPropertiesRule]{Server/Service/Engine/Host} Setting
> property 'debug' to '0' did not find a matching property. Nov 26, 2013
> 9:02:09 AM org.apache.tomcat.util.digester.SetPropertiesRule begin
> WARNING: [SetPropertiesRule]{Server/Service/Engine/Host} Setting
> property 'debug' to '0' did not find a matching property. Nov 26, 2013
> 9:02:09 AM org.apache.tomcat.util.digester.SetPropertiesRule begin
> WARNING: [SetPropertiesRule]{Server/Service/Engine/Host} Setting
> property 'debug' to '0' did not find a matching property. Nov 26, 2013
> 9:02:09 AM org.apache.tomcat.util.digester.SetPropertiesRule begin
> WARNING: [SetPropertiesRule]{Server/Service/Engine/Host} Setting
> property 'debug' to '0' did not find a matching property. Nov 26, 2013
> 9:02:09 AM org.apache.tomcat.util.digester.SetPropertiesRule begin
> WARNING: [SetPropertiesRule]{Server/Service/Engine/Host} Setting
> property 'debug' to '0' did not find a matching property. Nov 26, 2013
> 9:02:09 AM org.apache.tomcat.util.digester.SetPropertiesRule begin
> WARNING: [SetPropertiesRule]{Server/Service/Engine/Host} Setting
> property 'debug' to '0' did not find a matching property. Nov 26, 2013
> 9:02:09 AM org.apache.tomcat.util.digester.SetPropertiesRule begin
> WARNING: [SetPropertiesRule]{Server/Service/Engine/Host} Setting
> property 'debug' to '0' did not find a matching property. Nov 26, 2013
> 9:02:09 AM org.apache.tomcat.util.digester.SetPropertiesRule begin
> WARNING: [SetPropertiesRule]{Server/Service/Engine/Host} Setting
> property 'debug' to '0' did not find a matching property. Nov 26, 2013
> 9:02:10 AM org.apache.coyote.AbstractProtocol init INFO: Initializing
> ProtocolHandler ["http-bio-8080"] Nov 26, 2013 9:02:10 AM
> org.apache.coyote.AbstractProtocol init INFO: Initializing
> ProtocolHandler ["ajp-bio-8009"] Nov 26, 2013 9:02:10 AM
> org.apache.catalina.startup.Catalina load INFO: Initialization
> processed in 1148 ms Nov 26, 2013 9:02:10 AM
> org.apache.catalina.core.StandardService startInternal INFO: Starting
> service Catalina Nov 26, 2013 9:02:10 AM
> org.apache.catalina.core.StandardEngine startInternal INFO: Starting
> Servlet Engine: Apache Tomcat/7.0.26 ... Nov 26, 2013 9:02:25 AM
> org.apache.catalina.startup.HostConfig deployWAR INFO: Deploying web
> application archive
> /ingress/www/firstfx.ro/docs/test#ContactForm#contactpageTest2.war Nov
> 26, 2013 9:02:25 AM org.apache.catalina.startup.HostConfig deployWAR
> INFO: Deploying web application archive
> /ingress/www/firstfx.ro/docs/maria1_store.war Nov 26, 2013 9:02:25 AM
> org.apache.catalina.startup.HostConfig deployWAR INFO: Deploying web
> application archive /ingress/www/firstfx.ro/docs/test#newaccount.war
> Nov 26, 2013 9:02:26 AM org.apache.catalina.startup.HostConfig
> deployWAR INFO: Deploying web application archive
> /ingress/www/firstfx.ro/docs/test#ContactForm.war Nov 26, 2013 9:02:26
> AM org.apache.catalina.startup.HostConfig deployWAR INFO: Deploying
> web application archive
> /ingress/www/firstfx.ro/docs/test#ImageViewer.war Nov 26, 2013 9:02:26
> AM org.apache.catalina.startup.HostConfig deployDirectory INFO:
> Deploying web application directory
> /ingress/www/firstfx.ro/docs/workdesk Nov 26, 2013 9:02:26 AM
> org.apache.catalina.startup.SetContextPropertiesRule begin WARNING:
> [SetContextPropertiesRule]{Context} Setting property 'debug' to '100'
> did not find a matching property. Nov 26, 2013 9:02:28 AM
> org.apache.catalina.core.NamingContextListener addResource WARNING:
> Failed to register in JMX: javax.naming.NamingException: Could not
> load resource factory class [Root exception is
> java.lang.ClassNotFoundException:
> org.apache.tomcat.dbcp.dbcp.BasicDataSourceFactory] Nov 26, 2013
> 9:02:28 AM org.apache.catalina.startup.HostConfig deployWAR

There is no error in log file when i start tomcat, but why does it say [fail], when it actually works ?

share|improve this question
add comment

1 Answer

The failure is a failure to register a resource in JMX. That isn't fatal. It just means that the resource will not be visible when looking at the available MBeans e.g. via JConsole. Tomcat doesn't access resources via JMX so it doesn't matter to Tomcat (or the application) if the resource is not registered with JMX.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.