Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Does anyone of you installed svn 1.8.* together with neon on OS X Mavericks?

I followed this tutorial:

http://jason.pureconcepts.net/2012/10/updating-svn-mac-os-x/

But after trying to configure svn to use neon:

./configure --prefix=/usr/local --with-neon

I get this warning:

configure: WARNING: unrecognized options: --with-neon

Building and installation work fine after this, but of course I can not connect to WEBDAV repositories.

share|improve this question

4 Answers 4

to download the subversion-1.8.0 and subversion-1.8.9

http://archive.apache.org/dist/subversion/
Then unzip it.

to setup compiler environment

cd /Applications/Xcode.app/Contents/Developer/Toolchains/
ln -s XcodeDefault.xctoolchain OSX10.9.xctoolchain

to build serf (http client module) for svn

As @Ben Reser mentioned: Subversion no longer supports the neon http library with 1.8 and has moved exclusively to using the serf http library.

cd ~/Downloads/subversion-1.8.0
sh get-deps.sh serf
cd serf/
./configure
make
sudo make install

note: if you failed on ./configure

messages you may see

checking whether we are cross compiling... configure: error: in ~/Downloads/subversion-1.8.0/serf': configure: error: cannot run C compiled programs. If you meant to cross compile, use--host'. See `config.log' for more details

It might be missing of the Xcode developer tools installed.

xcode-select --install

to build svn 1.8.9

cd ~/Downloads/subversion-1.8.9
./configure --prefix=/usr/local --with-serf=/usr/local/serf
make
sudo make install

to add svn path to your ~/.bash_profile

export PATH=/usr/local/bin:$PATH
. ~/.bash_profile

to verify

svn --version

==> you should see

svn, version 1.8.9 (r1591380)

further more to update the svn client in Xcode

cd /Applications/Xcode.app/Contents/Developer/usr/bin/
sudo -s
mkdir svn_old
mv svn* svn_old/
ln -s /usr/local/bin/svn* ./
./svn --version
share|improve this answer

You need to set here a path to neon as well like this: --with-neon=/path_to_neon/neon-0.29.6.  It is not enough just to say --with-neon. :)

share|improve this answer
    
Yes, I also tried this before posting my problem: same warning. No WEBDAV access. –  Alex Nov 27 '13 at 19:18

Subversion no longer supports the neon http library with 1.8 and has moved exclusively to using the serf http library.

share|improve this answer

After extracting the ZIP archive I get this error invoking the shell script

MacBook-Pro:subversion-1.8.9 mario$ sh get-deps.sh serf
: command not found5: 
: command not found3: 
: command not found2: 
: invalid numbere 48: printf: 1
: command not found1: 
: command not found4: 
: command not found7: 
: command not found2: 
: command not found6: 
'et-deps.sh: line 68: syntax error near unexpected token `{
'et-deps.sh: line 68: `usage() {

After downloading the tar.gz archive and repeating the operation the shell script get-deps.sh ran successfully.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.