Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Possible Duplicate:
BIOS corrupted? How to proceed? Acer Travelmate 290

I have a older ACER Travelmate 290 (manufactured in 2002 or 2003), which I recently tried to upgrade to Ubuntu 9.10. After doing the upgrade process it appeared as if I had a problem with my x server configuration, as on the first reboot post-install I heard the Ubuntu startup sound, but had a black screen. I thought I would then reboot again to drop down into text-mode to trouble shoot the x configuration problem.

However, when I tried rebooting, something went wrong and since then when I start up the machine I get absolutely nothing except the first hardware check (i.e. HDD light flashes, CD/DVD drive spins, etc.). Other than that the screen remains totally black and I have no HDD or processor activity at all.

I have tried restarting it a number of time holding down all kinds of key combinations to try and coax it into the BIOS (if possible) with no luck. I have also tried putting in both a live Linux disc and a Windows install disk without any luck. With a disk in the drive it will spin for a few seconds and then stop.

All this has lead me to suspect that the BIOS is somehow corrupt (not sure about the right terminology). I have tried putting a new BIOS image and installer program downloaded from ACER on a USB key to see if it will run when I start up the machine, but no luck. I'm not sure if this method of interacting/updating/flashing the BIOS will work outside of Windows/DOS as both OSs are mentioned kind of ambiguously in the documentation.

I have also taken the laptop case apart and inspected the various cards and cannot find any obviously burned out components.

I'm not sure how to proceed at this point in terms of components to try, or how to try and load a new BIOS image onto the board. Any advice here would be great, especially from those with experience with this particular line of laptops.

Thanks!

share|improve this question
2  
Exact Duplicate to one already with replies - superuser.com/questions/68122/… –  MDMarra Nov 9 '09 at 20:41
add comment

migrated from serverfault.com Nov 9 '09 at 20:27

This question came from our site for professional system and network administrators.

marked as duplicate by MDMarra, Gnoupi, alex, Diago Nov 10 '09 at 4:39

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2 Answers

did some Google-ing and you are not the only one with this problem.

http://phorums.com.au/archive/index.php/t-206023.html

You may try what these guys are talking about and see if that helps.

share|improve this answer
add comment

If it's BIOS you're out of luck, because the only way to flash it (without a ROM burner) is to at least boot into DOS. However, try the tips in the reply that MarkM mentions.

share|improve this answer
add comment