Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Not sure if I should be creating a new post or replying to a very old post. But this is the guide that I followed.

Failure to connect to PPTP VPN in Ubuntu: VPN plugin failed: 1

I'm using ubuntu 12.04 server so have to setup pptp manually. I know my vpn server is working cos my Windows machines are able to connect and all the traffic gets routed through it.

using channel 9
Using interface ppp0
Connect: ppp0 <--> /dev/pts/2
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x5d1a0bd> <pcomp> <accomp>]
rcvd [LCP ConfReq id=0x1 <asyncmap 0x0> <auth chap MS-v2> <magic 0xc65ae795> <pcomp> <accomp>]
sent [LCP ConfAck id=0x1 <asyncmap 0x0> <auth chap MS-v2> <magic 0xc65ae795> <pcomp> <accomp>]
rcvd [LCP ConfAck id=0x1 <asyncmap 0x0> <magic 0x5d1a0bd> <pcomp> <accomp>]
sent [LCP EchoReq id=0x0 magic=0x5d1a0bd]
rcvd [LCP EchoReq id=0x0 magic=0xc65ae795]
sent [LCP EchoRep id=0x0 magic=0x5d1a0bd]
rcvd [CHAP Challenge id=0x1d <e1a713ac563e9796d19b53a80e508df6>, name = "pptpd"]
sent [CHAP Response id=0x1d <2c1b2fc24ee76a1dcb18ac30712c0c7e0000000000000000d2190880ae45acc1009f0db52a812809120fca16176b409c00>, name = "banz"]
rcvd [LCP EchoRep id=0x0 magic=0xc65ae795]
rcvd [CHAP Success id=0x1d "S=B3DD9D98BCB681671598BDC4AAF21A94BF3BA081 M=Access granted"]
CHAP authentication succeeded
sent [CCP ConfReq id=0x1 <mppe +H -M +S -L -D -C>]
rcvd [CCP ConfReq id=0x1 <mppe +H -M +S -L -D -C>]
sent [CCP ConfAck id=0x1 <mppe +H -M +S -L -D -C>]
rcvd [CCP ConfAck id=0x1 <mppe +H -M +S -L -D -C>]
MPPE 128-bit stateless compression enabled
sent [IPCP ConfReq id=0x1 <compress VJ 0f 01> <addr>]
rcvd [IPCP ConfReq id=0x1 <addr>]
sent [IPCP ConfAck id=0x1 <addr>]
rcvd [IPCP ConfRej id=0x1 <compress VJ 0f 01>]
sent [IPCP ConfReq id=0x2 <addr>]
rcvd [IPCP ConfNak id=0x2 <addr>]
sent [IPCP ConfReq id=0x3 <addr>]
rcvd [IPCP ConfAck id=0x3 <addr>]
local  IP address
remote IP address
Script /etc/ppp/ip-up started (pid 12796)
Script /etc/ppp/ip-up finished (pid 12796), status = 0x0

This is my routing table.

default         UG    100    0        0 eth0     *      UH    0      0        0 ppp0    *        U     0      0        0 eth0 UGH   0      0        0 eth0

The connection gets established but no traffic goes through it.

I'm noticing some errors in syslog.

Nov 28 10:52:50 xxx pptp[14050]: anon log[decaps_gre:pptp_gre.c:414]: buffering packet 69 (expecting 68, lost or reordered)
Nov 28 10:56:20 xxx pptp[14050]: anon log[decaps_gre:pptp_gre.c:414]: buffering packet 82 (expecting 81, lost or reordered)
Nov 28 10:56:20 xxxx pptp[14050]: anon log[decaps_gre:pptp_gre.c:414]: buffering packet 83 (expecting 81, lost or reordered)
share|improve this question
up vote 0 down vote accepted

No surprise it does not work: your routing table is set up as a point-to-point connection to your VPN server,; there are no other routes for anything, neither reaching the network behind the server, nor using the server to reach the Internet.

You can add the route behind the server with the command

  sudo route add -net dev ppp0

If you wish all of your traffic routed through your VPN server, you will need to issue also these two commands:

  sudo route delete default gw
  sudo route add -net gw dev ppp0

You may try whether this works, but I fear it may not. The reason is that such an incomplete routing table should never have been produced by the automatic scripts in the first place, so I suspect that there is something else fundamentally wrong at play here. If this is indeed the case, I suggest you google a good PPTP guide for your distro, there are many excellent ones around.

share|improve this answer
It worked after modifying the routes! So I need to add it to my /etc/ppp/ip-up.d/vpn file to do it automatically after connecting to vpn? – lbanz Nov 28 '13 at 6:38
Yes. Glad it was that simple. – MariusMatutiae Nov 28 '13 at 7:16

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.