Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've got issues getting ID 148f:5370 Ralink Technology, Corp. RT5370 Wireless Adapter to run ob an Ubuntu 12.04 box. I've downloaded latest sources from http://www.mediatek.com/_en/07_downloads/dl.php and compiled them with activated support for:

HAS_WPA_SUPPLICANT=y
HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=y

make and make install worked without any issues.

Also I added to blacklisted list:

blacklist rt2800usb
blacklist rt2870sta

When inserting the device I'm getting

[ 1625.120102] usb 1-1.2: new high-speed USB device number 7 using ehci_hcd
[ 1625.232103] 
[ 1625.232106] 
[ 1625.232107] === pAd = ffffc900228ea000, size = 598360 ===
[ 1625.232109] 
[ 1625.232241] <-- RTMPAllocAdapterBlock, Status=0
[ 1625.232419] Efuse Size=0x2d [2d0-2fc] 
[ 1625.232776] NVM is EFUSE
[ 1625.249500] ADDRCONF(NETDEV_UP): ra0: link is not ready

Syslog is extending this a bit:

Nov 19 17:27:03 betschwa kernel: [ 1625.120102] usb 1-1.2: new high-speed USB device number 7 using ehci_hcd
Nov 19 17:27:03 betschwa kernel: [ 1625.232103] 
Nov 19 17:27:03 betschwa kernel: [ 1625.232106] 
Nov 19 17:27:03 betschwa kernel: [ 1625.232107] === pAd = ffffc900228ea000, size = 598360 ===
Nov 19 17:27:03 betschwa kernel: [ 1625.232109] 
Nov 19 17:27:03 betschwa kernel: [ 1625.232241] <-- RTMPAllocAdapterBlock, Status=0
Nov 19 17:27:03 betschwa mtp-probe: checking bus 1, device 7: "/sys/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.2"
Nov 19 17:27:03 betschwa kernel: [ 1625.232419] Efuse Size=0x2d [2d0-2fc] 
Nov 19 17:27:03 betschwa kernel: [ 1625.232776] NVM is EFUSE
Nov 19 17:27:03 betschwa mtp-probe: bus: 1, device: 7 was not an MTP device
Nov 19 17:27:03 betschwa NetworkManager[1092]:    SCPlugin-Ifupdown: devices added (path: /sys/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.2/net/ra0, iface: ra0)
Nov 19 17:27:03 betschwa NetworkManager[1092]:    SCPlugin-Ifupdown: device added (path: /sys/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.2/net/ra0, iface: ra0): no ifupdown configuration found.
Nov 19 17:27:03 betschwa NetworkManager[1092]: <warn> failed to allocate link cache: (-10) Operation not supported
Nov 19 17:27:03 betschwa NetworkManager[1092]: <info> (ra0): driver does not support SSID scans (scan_capa 0x00).
Nov 19 17:27:03 betschwa NetworkManager[1092]: <info> (ra0): using WEXT for WiFi device control
Nov 19 17:27:03 betschwa NetworkManager[1092]: <error> [1384878423.166788] [nm-device-wifi.c:2591] real_update_permanent_hw_address(): (ra0): unable to read permanent MAC address (error 0)
Nov 19 17:27:03 betschwa NetworkManager[1092]: <info> (ra0): new 802.11 WiFi device (driver: 'usb' ifindex: 7)
Nov 19 17:27:03 betschwa NetworkManager[1092]: <info> (ra0): exported as /org/freedesktop/NetworkManager/Devices/6
Nov 19 17:27:03 betschwa NetworkManager[1092]: <info> (ra0): now managed
Nov 19 17:27:03 betschwa NetworkManager[1092]: <info> (ra0): device state change: unmanaged -> unavailable (reason 'managed') [10 20 2]
Nov 19 17:27:03 betschwa NetworkManager[1092]: <info> (ra0): bringing up device.
Nov 19 17:27:03 betschwa NetworkManager[1092]: <info> (ra0): deactivating device (reason 'managed') [2]
Nov 19 17:27:03 betschwa NetworkManager[1092]: <warn> (ra0): error 100 getting card mode
Nov 19 17:27:03 betschwa NetworkManager[1092]: <error> [1384878423.168059] [wifi-utils-wext.c:155] wifi_wext_set_mode(): (ra0): error setting mode 2
Nov 19 17:27:03 betschwa kernel: [ 1625.249500] ADDRCONF(NETDEV_UP): ra0: link is not ready
Nov 19 17:27:03 betschwa NetworkManager[1092]: <warn> (ra0): error 100 getting card mode

What else am I missing? Is there maybe any deb for Ubuntu anywhere available?

share|improve this question
    
Why are you using the Ralink drivers ? why not just use the default drivers in the kernel ? –  Lawrence Nov 28 '13 at 11:44
add comment

1 Answer

There are two possibilities. the first one is that you did not install the ralink firmware. Try

  sudo apt-get install linux-firmware-nonfree

then turn the pc off and then back on, and see if it works.

If this is not enough, then open a terminal, create an empty directory, and issue these commands:

 wget http://www.kernel.org/pub/linux/kernel/projects/backports/stable/v3.12.1/backports-3.12.1-1.tar.bz2
 tar xvf backports-3.12.1-1.tar.bz2
 cd backports-3.12.1-1
 make defconfig-wifi
 make
 sudo make install

UN-blacklist rt2800usb, because this is going to be precisely your module. Turn off your pc, then back on, it should work now. You can check it by means of

 modinfo rt2800usb | grep 148F | grep 5370

which should return

 alias:          usb:v148Fp5370d*dc*dsc*dp*ic*isc*ip*in*

If it does not work, blacklist the competitor module, the one you tried unsuccessfully to install above, turn the pc off and then back on, and hopefully this time it will work.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.