Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Windows 8 installed on one of my HDD and I want to install Linux Mint on my unused SSD.

The point is, I want to install another operating system to the unused hard driver in a way, that it does't interfere with Windows 8 default boot sequence. My plan is to use the Boot Option Menu(pressing F12) at boot time to select desired HDD to get different OS running. I don't want Mint to implement a boot loader on my primary storage.

The problem is, I am using Lenovo Ideapad Y500(UEFI firmware) and since it came with Windows 8 pre-installed, I am assuming there is some hardware binding with the OS. i.e. OEM SLP key (Original Equipment Manufacturer - System Locked Pre-installation), One key recovery feature etc etc.

Question is, is there going to be any problem if I just boot from live Linux Mint and install it to my SSD and try to boot it using Boot menu? How I can install Linux Mint without interfering with Windows 8?

I want to keep everything separate from the hardware level.

Thanks!

Edit : Since I am on Laptop I didn't find a way to disconnect/remove my primary HDD without opening it up and I don't want to do that.

share|improve this question
2  
If you install Ubuntu on the secondary hdd ( your ssd ) it should not modify the primary storage device. One way to insure this is to remove the primary storage device. –  Ramhound Nov 29 '13 at 18:57
    
I've done something similar. To be safe, I disconnected the hard drive, installed Ubuntu, and then reconnected the hard drive. –  joat Nov 30 '13 at 3:20
    
If I open my laptop, it would void the warranty. I tried disabling my primary HDD from BIOS, but couldn't find how to. –  iamcreasy Nov 30 '13 at 19:32
add comment

2 Answers 2

up vote 2 down vote accepted
+50

All I had to do, when I installed Fedora a year ago, was to tell the Fedora installer (anaconda) to install the GRUB boot loader to desired HDD (SSD in your case).

share|improve this answer
1  
Detailed answer here. –  iamcreasy Feb 9 at 9:54
add comment

You have to go into bios and under boot options enable legacy boot you want on and/or there should be an option for secure booting you want off if the legacy boot option doesnt work which in most cases it should. Then when you boot with f12 it should allow you to choose between hard drives.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.