Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Vista x64 Host and an Ubuntu Guest.

From my host I would like to access my Ubuntu Guest via its IP address. From my Ubuntu Guest I would like to access my Vista Host and the Internets.

Theoretically, I should be able to just enable "Bridged Adapter" networking for my adapter and all should be well.

But its not.

Has anyone managed to get this working, if so how?

share|improve this question
add comment

2 Answers 2

up vote 2 down vote accepted

I managed to work around this, by changing the networking to use the "Intel Pro/1000 network driver", so far so good.

This may be a bug in 3.0.2 with Vista x64, who knows.

share|improve this answer
    
Sometimes bridging doesn't work with wifi adapters, though it may have only been a problem wither earlier cards/drivers. –  Mark Renouf Jul 17 '09 at 9:04
    
Its not a wifi adapter, in fact it seem to work ... if I enable it with other adapters, by its self it refuses to work. –  Sam Saffron Jul 17 '09 at 9:10
add comment

As long as both machines are getting different and valid IP addresses from the network this should work. However make sure you have the VirtualBox Guest Additions installed. If not I would look at:

  • Firewall Settings

I would assume you can successfully ping the host from the guest and the other way around.

The other option is to use Shared Folders, which allows you to access host directly.

Also check that you have bound the Virtual Machine to the correct network card. This is relevant especially when you have Wireless.

  • Virtual Machine Settings
  • Network
  • Adapter 1 (Select the one you are using)
  • Adapter Type: (Leave as is)
  • Attached to: Bridged Adapter
  • Name: (Select the correct physical card here)

Also make sure the information box is not giving a big red error at this point.

share|improve this answer
    
I can not ping my guest from my host, and it refuses to get an ip address from my dhcp server, if i assign manually it does not work as well –  Sam Saffron Jul 17 '09 at 8:35
    
Have you got the VirtualBox Guest Additions installed? Have you configured VirtualBox to bind to the correct network card? –  Diago Jul 17 '09 at 8:46
    
Also I assume you have restarted the VM after the change? –  Diago Jul 17 '09 at 8:47
    
See my answer, I worked around it. I don't know why but no matter what I did bridged refused to work, so I use NAT + Host only instead and all is good. –  Sam Saffron Jul 17 '09 at 8:52
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.