Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a little problem when trying to install graphics drivers for my nVidia GeForce 510.

I have tried downloading the drivers from the nVidia website, they installed without any errors, but in the Windows Hardware management thing, I get:

Code 37 - Windows could not initialize the appropriate drivers


  • Acer Aspire M3970
  • Intel i5 + Intel HD graphics
  • nVidia GeForce 510
  • Windows 7 64bit, official version (came pre-installed)

Could it be that I need to disable the Intel HD graphics? If yes, how?

share|improve this question
try this driver: – magicandre1981 Nov 30 '13 at 14:20
I have already installed that driver and tried reinstalling – user2674567 Nov 30 '13 at 14:38

Do not disable Intel graphics (why?). Instead, try updating Intel drivers first.

Then reset your BIOS settings to defaults. Some laptop BIOSes have Optimus bugs that causes them to permanently switch to a legacy mode, where NVIDIA GPU is unavailable. Restoring default settings may fix the problem.

share|improve this answer
I will try updating the Intel HD drivers and let you know more. Thanks for informing me to not disable them – user2674567 Nov 30 '13 at 14:39
I get an error "This program is not compatible with your computer" when I try to install the Intel drivers, I tried different versions – user2674567 Nov 30 '13 at 16:57
Where did you download them? Intel's website has terrible download section, getting older drivers from laptop manufacturer's website may be a good option. – gronostaj Nov 30 '13 at 17:32
I see, I'll try downloading from Acer's site. – user2674567 Dec 2 '13 at 12:36
It didn't help.. – user2674567 Dec 4 '13 at 18:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .