Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Dell XPS 630i that came loaded with Windows XP. Wake-on-LAN has always worked fine on it; I send the magic packet and the machine comes to life. Since installing Windows 7, however, it stopped working. What could be the problem?

share|improve this question

3 Answers 3

up vote 2 down vote accepted

Windows 7 has some more flexible power options (accessible from Control Panel>Power Options), which include per-device settings -- these affect what devices are able to do what when the computer is on, sleeping, or hibernating.

I haven't had this particular issue, but yours could have something to do with these power settings.

The first thing I'd do is the standard advice -- backup the machine, make sure you have the latest BIOS, and make sure you have the latest drivers for the LAN.

If that doesn't help, fiddle with the power settings. Give everything max performance, and if that solves the issue, start scaling back power usage as far as you can go without losing WoL.

Not a solution, but a direction. Good luck.

share|improve this answer
    
Updating the NIC driver did it. –  Josh Hinman Dec 9 '09 at 2:47
    
Installing the driver & software from Intel worked for my Intel PRO/1000 EB adapter. After that, the Intel software replaced the Power Management tab in the adapter device properties with their own settings. "Wake on Magic Packet" was checked, but alas, "Wake on Magic Packed from power off state" was not. It seems Windows was unable to set that property without Intel's software. –  Kyle Gagnet Jan 27 '10 at 14:59

Firstly, I can give hope, Wake-on-Lan works better now I have upgraded to Windows 7.

Secondly, I take this route to the configuration settings.

Control Panel, Network and Internet, Network Adapter. Properties of Your particular NIC, Configure button (Key Point), Power Management.

I also have a look at the Device Manager to see what other devices may, or may not trigger Wake-on-Lan.

share|improve this answer

I had the same problem Optiplex 780, wouldnt wake on lan when windows7 is shutdown.

Solution: Update NIC driver to the newest from dell.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.